openbox_3.5.0: Updated recipe so that it actually builds
authorMichael Mrozek <EvilDragon@openpandora.org>
Tue, 27 Nov 2012 00:48:59 +0000 (01:48 +0100)
committerMichael Mrozek <EvilDragon@openpandora.org>
Tue, 27 Nov 2012 00:48:59 +0000 (01:48 +0100)
recipes/openbox/openbox_3.5.0.bb

index 3f6d767..a872178 100644 (file)
@@ -11,29 +11,22 @@ SRC_URI[sha256sum] = "6fa90016530b3aa6102e254079461977439398531fb23e7ec076ff2c14
 
 inherit autotools gettext update-alternatives
 
-ALTERNATIVE_PATH = "${bindir}/openbox"
-ALTERNATIVE_NAME = "x-window-manager"
-ALTERNATIVE_LINK = "${bindir}/x-window-manager"
-ALTERNATIVE_PRIORITY = "10"
-
 EXTRA_OECONF += "--with-plugins=none"
 
-PACKAGES =+ "${PN}-core ${PN}-lxde ${PN}-gnome"
+PACKAGES += "lxde-icon-theme"
+FILES_${PN} += "${datadir}/lxde/ ${datadir}/lxpanel ${datadir}/xsessions"
+FILES_lxde-icon-theme = "${datadir}/icons"
 
-PACKAGES_DYNAMIC += "^${PN}-theme-.*"
+PACKAGES_DYNAMIC += "${PN}-theme-*"
 
 python populate_packages_prepend() {
-    theme_dir = d.expand('${datadir}/themes/')
-    theme_name = d.expand('${PN}-theme-%s')
-    do_split_packages(d, theme_dir, '(.*)', theme_name, '${PN} theme for %s', extra_depends='', allow_dirs=True)
-}
-
-RDEPENDS_${PN} += "${PN}-core"
-FILES_${PN}-core = "${bindir}/openbox ${libdir}/*${SOLIBS}"
-
-FILES_${PN}-lxde += "${datadir}/lxde/ \
-                     ${datadir}/lxpanel \
-                     ${datadir}/xsessions \
-                     ${datadir}/icons"
-
-FILES_${PN}-gnome += "${datadir}/gnome/"
+        theme_dir = bb.data.expand('${datadir}/themes/', d)
+        theme_name = bb.data.expand('${PN}-theme-%s', d)
+       do_split_packages(d, theme_dir, '(.*)', theme_name, '${PN} theme for %s', extra_depends='', allow_dirs=True)
+        }
+                        
+ALTERNATIVE_PATH = "${bindir}/openbox"
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PRIORITY = "10"
+                        
\ No newline at end of file