libsynthesis: Add new recipe for a syncml engine (from poky).
authorStefan Schmidt <stefan@datenfreihafen.org>
Tue, 4 Aug 2009 23:45:13 +0000 (23:45 +0000)
committerStefan Schmidt <stefan@datenfreihafen.org>
Tue, 4 Aug 2009 23:45:13 +0000 (23:45 +0000)
conf/distro/include/sane-srcrevs.inc
recipes/libsynthesis/libsynthesis_git.bb [new file with mode: 0644]

index eaa988b..8757a20 100644 (file)
@@ -111,6 +111,7 @@ SRCREV_pn-libmokopanelui2 ?= "4568"
 SRCREV_pn-libmokoui2 ?= "4342"
 SRCREV_pn-libowl ?= "277"
 SRCREV_pn-librfid ?= "2094"
+SRCREV_pn-libsynthesis ?= "70f0065aa3b085bdf059830f95e5b5766eecb0bb"
 SRCREV_pn-libw100 ?= "47"
 SRCREV_pn-libxcalibrate ?= "209d83af61ed38a002c8096377deac292b3e396c"
 SRCREV_pn-libxosd ?= "627"
diff --git a/recipes/libsynthesis/libsynthesis_git.bb b/recipes/libsynthesis/libsynthesis_git.bb
new file mode 100644 (file)
index 0000000..3571a75
--- /dev/null
@@ -0,0 +1,18 @@
+DESCRIPTION = "Synthesis SyncML Engine"
+SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git"
+LICENSE = "LGPLv2.1"
+PV = "0.0+git${SRCREV}"
+PR = "r1"
+
+DEPENDS = "libpcre"
+
+S = "${WORKDIR}/git"
+
+inherit autotools_stage
+
+do_configure_prepend () {
+       cd ${S}/src
+       ${S}/src/gen-makefile-am.sh
+       cd ${S}
+}
+