guile-native: Add patch to inhibit generation of linemarkers from cpp.
authorRobert P. J. Day <rpjday@crashcourse.ca>
Thu, 19 Nov 2009 17:41:03 +0000 (17:41 +0000)
committerPhilip Balister <philip@balister.org>
Thu, 19 Nov 2009 22:18:07 +0000 (17:18 -0500)
Add the "-P" option to inhibit generation of linemarkers in the output
from the preprocessor.

Signed-off-by: Robert P. J. Day <rpjday@crashcourse.ca>
recipes/guile/files/cpp-linemarkers.patch [new file with mode: 0644]
recipes/guile/guile-native_1.8.5.bb
recipes/guile/guile-native_1.8.6.bb

diff --git a/recipes/guile/files/cpp-linemarkers.patch b/recipes/guile/files/cpp-linemarkers.patch
new file mode 100644 (file)
index 0000000..3e48932
--- /dev/null
@@ -0,0 +1,8 @@
+--- guile.orig/libguile/guile-snarf-docs.in    2009-07-03 18:19:00.000000000 -0400
++++ guile/libguile/guile-snarf-docs.in 2009-11-19 12:55:32.487266268 -0500
+@@ -23,4 +23,4 @@
+ ## Let the user override the preprocessor autoconf found.
+ test -n "${CPP+set}" || CPP="@CPP@"
+
+-${CPP} -DSCM_MAGIC_SNARF_DOCS "$@"
++${CPP} -P -DSCM_MAGIC_SNARF_DOCS "$@"
index 9c2eb13..5c999db 100644 (file)
@@ -4,6 +4,7 @@ DEPENDS = "libtool (< 2)"
 
 SRC_URI = "http://ftp.gnu.org/pub/gnu/guile/guile-${PV}.tar.gz \
            file://configure-fix.patch;patch=1 \
+           file://cpp-linemarkers.patch;patch=1 \
           "
 
 PR = "r1"
index d511807..2f87c48 100644 (file)
@@ -1,4 +1,5 @@
 require guile-native.inc
 SRC_URI = "http://ftp.gnu.org/pub/gnu/guile/guile-${PV}.tar.gz \
            file://configure-fix.patch;patch=1 \
+           file://cpp-linemarkers.patch;patch=1 \
           "