libqpe-opie: Dont inherit opie.
authorKhem Raj <raj.khem@gmail.com>
Mon, 21 Dec 2009 07:02:25 +0000 (23:02 -0800)
committerKhem Raj <raj.khem@gmail.com>
Mon, 21 Dec 2009 07:02:25 +0000 (23:02 -0800)
* inhetriting opie caused other problems like
  circular dependencies in do_stage task etc.
  therefore dont inherit opie just to get a
  variable instead define the variable here.

* Add a note about the above in the cvs recipe
  so in future updates happens correctly.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
recipes/libqpe/libqpe-opie.inc
recipes/libqpe/libqpe-opie_cvs.bb

index 3cecedd..5795e5c 100644 (file)
@@ -10,7 +10,6 @@ INC_PR = "r7"
 S = "${WORKDIR}/library"
 
 inherit palmtop
-inherit opie
 
 OE_QMAKE_CXXFLAGS := "${@oe_filter_out('-fno-rtti', '${OE_QMAKE_CXXFLAGS}', d)}"
 QMAKE_PROFILES = "library.pro"
index 8ed2f4d..16b6414 100644 (file)
@@ -1,5 +1,11 @@
 require ${PN}.inc
 
+# OPIE_CVS_PV is defined in opie.bbclass
+# but this recipe does not inherit opie
+# so any updates to OPIE_CVS_PV should happen
+# in both places.
+
+OPIE_CVS_PV ?= "1.2.2+cvs${SRCDATE}"
 PV = "${OPIE_CVS_PV}"
 PR = "${INC_PR}.0"