devicekit: Update to remove host dependency on Docbook XSLT files.
authorDavid-John Willis <John.Willis@Distant-earth.com>
Tue, 27 Oct 2009 21:34:32 +0000 (21:34 +0000)
committerKoen Kooi <koen@openembedded.org>
Wed, 28 Oct 2009 09:16:29 +0000 (10:16 +0100)
* Bump PR
* Update recipe to sed out the -nonet in the documentation XSLT conversion removing the reliance of the Docbook XSLT templates being installed on the host system (it will grab them from the net however).
* Note: Another (maybe better) fix would be to package up docbook-xsl but that is overkill for these two recipes.

recipes/devicekit/devicekit-power_009.bb
recipes/devicekit/devicekit_003.bb

index 58f638c..0622d4a 100644 (file)
@@ -7,6 +7,10 @@ S = "${WORKDIR}/DeviceKit-power-${PV}"
 
 inherit autotools pkgconfig
 
+do_configure_prepend() {
+       sed -i -e s:-nonet:\:g ${S}/doc/man/Makefile.am
+}      
+
 do_stage() {
         autotools_stage_all
 }
index a57ca88..3439290 100644 (file)
@@ -2,13 +2,16 @@ DESCRIPTION = "DeviceKit is a simple system service that a) can enumerate device
 LICENSE = "GPLv2"
 DEPENDS = "udev dbus-glib glib-2.0"
 
+PR = "r1"
+
 SRC_URI = "http://hal.freedesktop.org/releases/DeviceKit-${PV}.tar.gz"
 S = "${WORKDIR}/DeviceKit-${PV}"
 
+do_configure_prepend() {
+       sed -i -e s:-nonet:\:g ${S}/doc/man/Makefile.am
+}      
+
 inherit autotools_stage
 AUTOTOOLS_STAGE_PKGCONFIG = "1"
 
 FILES_${PN} += "${datadir}/dbus-1/"
-
-
-