rfkill: fix install and remove bogus DEPENDS, it's not using libnl nor pkgconfig...
authorKoen Kooi <koen@openembedded.org>
Fri, 11 Feb 2011 09:40:26 +0000 (10:40 +0100)
committerKoen Kooi <koen@openembedded.org>
Fri, 11 Feb 2011 09:41:31 +0000 (10:41 +0100)
Signed-off-by: Koen Kooi <koen@openembedded.org>
recipes/rfkill/rfkill/0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch [new file with mode: 0644]
recipes/rfkill/rfkill_0.4.bb

diff --git a/recipes/rfkill/rfkill/0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch b/recipes/rfkill/rfkill/0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch
new file mode 100644 (file)
index 0000000..c6f60d0
--- /dev/null
@@ -0,0 +1,30 @@
+From db764080e54f8f998c28ef8dab78da8b8d1d1420 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Fri, 11 Feb 2011 10:35:40 +0100
+Subject: [PATCH] rfkill makefile: don't use -t, the OE install wrapper dislikes it
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ Makefile |    4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 8d6c700..3652690 100644
+--- a/Makefile
++++ b/Makefile
+@@ -53,10 +53,10 @@ check:
+ install: rfkill rfkill.8.gz
+       @$(NQ) ' INST rfkill'
+       $(Q)$(MKDIR) $(DESTDIR)$(SBINDIR)
+-      $(Q)$(INSTALL) -m 755 -t $(DESTDIR)$(SBINDIR) rfkill
++      $(Q)$(INSTALL) -m 755 rfkill $(DESTDIR)$(SBINDIR) 
+       @$(NQ) ' INST rfkill.8'
+       $(Q)$(MKDIR) $(DESTDIR)$(MANDIR)/man8/
+-      $(Q)$(INSTALL) -m 644 -t $(DESTDIR)$(MANDIR)/man8/ rfkill.8.gz
++      $(Q)$(INSTALL) -m 644 rfkill.8.gz $(DESTDIR)$(MANDIR)/man8/
+ clean:
+       $(Q)rm -f rfkill *.o *~ *.gz version.c *-stamp
+-- 
+1.6.6.1
+
index 6691049..d432080 100644 (file)
@@ -2,19 +2,17 @@ DESCRIPTION = "rfkill CLI utility"
 HOMEPAGE = "http://linuxwireless.org/en/users/Documentation/rfkill"
 SECTION = "base"
 LICENSE = "BSD"
-PR = "r0"
+PR = "r1"
 
-DEPENDS = "libnl pkgconfig"
+SRC_URI = "http://wireless.kernel.org/download/${PN}/${P}.tar.bz2 \
+           file://0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch"
 
-SRC_URI = "http://wireless.kernel.org/download/${PN}/${P}.tar.bz2"
+SRC_URI[md5sum] = "727892c0fb35c80ee3849fbe89b45350"
+SRC_URI[sha256sum] = "ca10e4827a5f0a36e093aee6ad81b5febf81f8097d7d858889ac51ff364168c1"
 
 do_compile() {
-       oe_runmake
+        oe_runmake
 }
-
 do_install() {
-       oe_runmake DESTDIR=${D} install
+        oe_runmake DESTDIR=${D} install
 }
-
-SRC_URI[md5sum] = "727892c0fb35c80ee3849fbe89b45350"
-SRC_URI[sha256sum] = "ca10e4827a5f0a36e093aee6ad81b5febf81f8097d7d858889ac51ff364168c1"