mgetty: add mgetty-fax to the package and honor our LDLFAGS
authorwoglinde <woglinde@rhein.zuhause.netz>
Thu, 25 Jun 2009 19:33:22 +0000 (21:33 +0200)
committerwoglinde <woglinde@rhein.zuhause.netz>
Thu, 25 Jun 2009 20:31:59 +0000 (22:31 +0200)
recipes/mgetty/mgetty-1.1.30/faxqhelper_ldflags.patch [new file with mode: 0644]
recipes/mgetty/mgetty-1.1.30/newslock_ldflags.patch [new file with mode: 0644]
recipes/mgetty/mgetty_1.1.30.bb

diff --git a/recipes/mgetty/mgetty-1.1.30/faxqhelper_ldflags.patch b/recipes/mgetty/mgetty-1.1.30/faxqhelper_ldflags.patch
new file mode 100644 (file)
index 0000000..4d3ea24
--- /dev/null
@@ -0,0 +1,13 @@
+Index: mgetty-1.1.30/fax/Makefile
+===================================================================
+--- mgetty-1.1.30.orig/fax/Makefile    2009-05-09 22:00:37.814162343 +0200
++++ mgetty-1.1.30/fax/Makefile 2009-05-09 22:01:04.209581406 +0200
+@@ -36,7 +36,7 @@
+       @cd .. ; $(MAKE) sedscript
+
+ faxq-helper: faxq-helper.o 
+-      $(CC) $(CFLAGS) -o faxq-helper faxq-helper.o
++      $(CC) $(CFLAGS) $(LDFLAGS) -o faxq-helper faxq-helper.o
+
+ faxq-helper.o: faxq-helper.c
+       $(CC) $(CFLAGS) -DFAX_SPOOL_OUT=\"$(FAX_SPOOL_OUT)\" \
diff --git a/recipes/mgetty/mgetty-1.1.30/newslock_ldflags.patch b/recipes/mgetty/mgetty-1.1.30/newslock_ldflags.patch
new file mode 100644 (file)
index 0000000..a4fc814
--- /dev/null
@@ -0,0 +1,13 @@
+Index: mgetty-1.1.30/Makefile
+===================================================================
+--- mgetty-1.1.30.orig/Makefile        2009-05-09 21:55:50.072936310 +0200
++++ mgetty-1.1.30/Makefile     2009-05-09 21:56:09.401939481 +0200
+@@ -569,7 +569,7 @@
+       ./sedscript <sendfax.cfg.in >sendfax.config
+
+ newslock: compat/newslock.c
+-      $(CC) $(CFLAGS) -o newslock compat/newslock.c
++      $(CC) $(CFLAGS) $(LDFLAGS) -o newslock compat/newslock.c
+
+ # internal: use this to create a "clean" mgetty+sendfax tree
+ bindist: all doc-all sedscript
index 375ea90..37a830f 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "The mgetty package contains an intelligent \
 getty for allowing logins over a serial line (such as \
 through a modem) and receiving incoming faxes."
 LICENSE = "GPL"
-PR ="r3"
+PR ="r4"
 
 # The source can no longer be found at ${DEBIAN_MIRROR}/main/m/mgetty/mgetty_${PV}.orig.tar.gz
 # so the nslu2-linux project has mirrored it until someone updates this package to a newer version.
@@ -38,6 +38,8 @@ SRC_URI = "http://nslu.sf.net/downloads/mgetty_1.1.30.orig.tar.gz \
            file://51-pending-faxq-time;patch=1 \
            file://52-pending-metamail;patch=1 \
            file://install.patch;patch=1 \
+          file://newslock_ldflags.patch;patch=1 \
+          file://faxqhelper_ldflags.patch;patch=1 \
            file://policy.h \
            file://voice-defs.h"
 
@@ -79,3 +81,7 @@ do_install () {
 
 CONFFILES_${PN} = "${sysconfdir}/mgetty/mgetty.config \
        ${sysconfdir}/mgetty/login.config ${sysconfdir}/mgetty/sendfax.config"
+
+FILES_${PN} += "${libdir}/mgetty-fax"
+
+FILES_${PN}-dbg += "${libdir}/mgetty-fax/.debug"