python-pyid3lib: fix compiling for gcc4.x
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>
Sun, 17 Jan 2010 15:06:29 +0000 (16:06 +0100)
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>
Sun, 17 Jan 2010 15:06:29 +0000 (16:06 +0100)
recipes/python/python-pyid3lib/gcc4-fix.patch [new file with mode: 0644]
recipes/python/python-pyid3lib_0.5.1.bb

diff --git a/recipes/python/python-pyid3lib/gcc4-fix.patch b/recipes/python/python-pyid3lib/gcc4-fix.patch
new file mode 100644 (file)
index 0000000..cfd9727
--- /dev/null
@@ -0,0 +1,13 @@
+Index: pyid3lib-0.5.1/pyid3lib.cc
+===================================================================
+--- pyid3lib-0.5.1.orig/pyid3lib.cc
++++ pyid3lib-0.5.1/pyid3lib.cc
+@@ -1013,7 +1013,7 @@
+     {
+         ID3_Frame* frame;
+       const char* str;
+-      char* slash;
++      const char* slash;
+         ID3_Field* fld;
+       int i;
index bf7e3d0..1d24b34 100644 (file)
@@ -4,11 +4,12 @@ PRIORITY = "optional"
 LICENSE = "LGPL"
 DEPENDS = "id3lib"
 SRCNAME = "pyid3lib"
-PR = "r1"
+PR = "r2"
 
-SRC_URI = "${SOURCEFORGE_MIRROR}/pyid3lib/${SRCNAME}-${PV}.tar.bz2"
+SRC_URI = "\
+  ${SOURCEFORGE_MIRROR}/pyid3lib/${SRCNAME}-${PV}.tar.bz2\
+  file://gcc4-fix.patch;patch=1 \
+"
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 inherit distutils
-
-