sysvinit: allow /proc to be mounted without /etc/fstab
authorPhil Blundell <philb@gnu.org>
Fri, 5 Jun 2009 14:21:56 +0000 (15:21 +0100)
committerPhil Blundell <philb@gnu.org>
Fri, 5 Jun 2009 14:21:56 +0000 (15:21 +0100)
Acked-by: Leon Woestenberg <leon@sidebranch.com>
recipes/sysvinit/sysvinit/rcS
recipes/sysvinit/sysvinit_2.86.bb

index e7a7e61..e1c8b57 100755 (executable)
@@ -14,7 +14,7 @@ export PATH runlevel prevlevel
 
 #      Make sure proc is mounted
 #
-[ -d "/proc/1" ] || mount /proc
+[ -d "/proc/1" ] || mount proc /proc -t proc
 
 #
 #      See if system needs to be setup. This is ONLY meant to
index e65391a..cc7b913 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "System-V like init."
 SECTION = "base"
 LICENSE = "GPL"
 HOMEPAGE = "http://freshmeat.net/projects/sysvinit/"
-PR = "r53"
+PR = "r54"
 
 # USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf.
 # Set PACKAGE_ARCH appropriately.