valgrind: hacks for the old OE tree
authorGrazvydas Ignotas <notasas@gmail.com>
Tue, 20 May 2014 21:12:26 +0000 (00:12 +0300)
committerGrazvydas Ignotas <notasas@gmail.com>
Tue, 20 May 2014 21:12:26 +0000 (00:12 +0300)
recipes/valgrind/valgrind_3.9.0.bb

index 3c6aa13..caef106 100644 (file)
@@ -1,25 +1,26 @@
 SUMMARY = "Valgrind memory debugger and instrumentation framework"
 HOMEPAGE = "http://valgrind.org/"
 BUGTRACKER = "http://valgrind.org/support/bug_reports.html"
-LICENSE = "GPLv2 & GPLv2+ & BSD"
+LICENSE = "GPLv2 GPLv2+ BSD"
 LIC_FILES_CHKSUM = "file://COPYING;md5=c46082167a314d785d012a244748d803 \
                     file://include/pub_tool_basics.h;beginline=1;endline=29;md5=e7071929a50d4b0fc27a3014b315b0f7 \
                     file://include/valgrind.h;beginline=1;endline=56;md5=92df8a1bde56fe2af70931ff55f6622f \
                     file://COPYING.DOCS;md5=8fdeb5abdb235a08e76835f8f3260215"
 
 X11DEPENDS = "virtual/libx11"
-DEPENDS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '${X11DEPENDS}', '', d)}"
+# DEPENDS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '${X11DEPENDS}', '', d)}"
+DEPENDS = ${X11DEPENDS}
 PR = "r8"
 
 SRC_URI = "http://www.valgrind.org/downloads/valgrind-${PV}.tar.bz2 \
-           file://fixed-perl-path.patch \
-           file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \
-           file://sepbuildfix.patch \
-           file://glibc-2.19.patch \
-           file://force-nostabs.patch \
-           file://remove-arm-variant-specific.patch \
-           file://remove-ppc-tests-failing-build.patch \
-           file://add-ptest.patch \
+           file://fixed-perl-path.patch;patch=1 \
+           file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch;patch=1 \
+           file://sepbuildfix.patch;patch=1 \
+           file://glibc-2.19.patch;patch=1 \
+           file://force-nostabs.patch;patch=1 \
+           file://remove-arm-variant-specific.patch;patch=1 \
+           file://remove-ppc-tests-failing-build.patch;patch=1 \
+           file://add-ptest.patch;patch=1 \
            file://run-ptest \
           "
 
@@ -29,7 +30,8 @@ SRC_URI[sha256sum] = "e6af71a06bc2534541b07743e1d58dc3caf744f38205ca3e5b5a0bdf37
 COMPATIBLE_HOST = '(i.86|x86_64|powerpc|powerpc64).*-linux'
 COMPATIBLE_HOST_armv7a = 'arm.*-linux'
 
-inherit autotools ptest
+# inherit autotools ptest
+inherit autotools
 
 EXTRA_OECONF = "--enable-tls --without-mpicc"
 EXTRA_OECONF_armv7a = "--enable-tls -host=armv7-none-linux-gnueabi --without-mpicc"
@@ -46,9 +48,9 @@ FILES_${PN}-dbg += "${libdir}/${PN}/*/.debug/*"
 
 # valgrind needs debug information for ld.so at runtime in order to
 # redirect functions like strlen.
-RRECOMMENDS_${PN} += "${TCLIBC}-dbg"
+RRECOMMENDS_${PN} += "glibc-dbg"
 
-RDEPENDS_${PN}-ptest += " sed perl eglibc-utils"
+RDEPENDS_${PN}-ptest += " sed perl glibc-utils"
 
 do_compile_ptest() {
     oe_runmake check