php_5.2.6.bb : add dependency on mysql, remove sqlite pdo as it doesnt build
authorGraeme Gregory <gg@slimlogic.co.uk>
Wed, 9 Dec 2009 21:11:33 +0000 (14:11 -0700)
committerGraeme Gregory <dp@xora.org.uk>
Wed, 9 Dec 2009 21:13:28 +0000 (21:13 +0000)
Seems according to google to be some issue of bison vs lemon but the
build failure seems to be fairly common.

recipes/php/php_5.2.6.bb

index 0d9e1f4..8723a1e 100644 (file)
@@ -1,8 +1,8 @@
 require php.inc
 
-DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native"
+DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native mysql"
 
-PR = "r6"
+PR = "r7"
 
 SRC_URI += "file://pear-makefile.patch;patch=1 \
        file://string.c.patch;patch=1 "
@@ -24,6 +24,7 @@ EXTRA_OECONF = "    --without-iconv \
                     --with-libxml-dir=${STAGING_BINDIR_CROSS} \
                     --with-mysql="${STAGING_DIR_TARGET}${layout_exec_prefix}" \
 #                   --with-mysqli = "${STAGING_BINDIR_NATIVE}/mysql_config" \
+                    --without-pdo-sqlite \
                "
 
 export LD_LIBRARY_PATH = "${STAGING_LIBDIR}"