bustle-dbus-monitor: new recipe; monitoring utility for the Bustle D-Bus suite
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>
Wed, 22 Apr 2009 15:18:25 +0000 (17:18 +0200)
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>
Wed, 22 Apr 2009 15:19:18 +0000 (17:19 +0200)
TODO: add eavesdropping magic in postinstall/prerm

recipes/bustle/bustle-dbus-monitor_0.2.0.bb [new file with mode: 0644]

diff --git a/recipes/bustle/bustle-dbus-monitor_0.2.0.bb b/recipes/bustle/bustle-dbus-monitor_0.2.0.bb
new file mode 100644 (file)
index 0000000..4d4768f
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "The monitoring utilitiy for the Bustle D-Bus diagram application."
+HOMEPAGE = "http://www.willthompson.co.uk/bustle"
+DEPENDS = "dbus glib-2.0"
+LICENSE = "LGPL"
+SECTION = "console/network"
+
+SRC_URI = "http://www.willthompson.co.uk/bustle/releases/bustle-${PV}.tar.gz"
+S = "${WORKDIR}/bustle-${PV}"
+
+do_compile() {
+       ${CC} ${CFLAGS} ${LDFLAGS} `pkg-config --cflags --libs dbus-1 glib-2.0` -o bustle-dbus-monitor bustle-dbus-monitor.c
+}
+
+do_install() {
+       install -d ${D}${sbindir}
+       install -m 0755 bustle-dbus-monitor ${D}${sbindir}
+}
+
+FILES_${PN} += "${sbindir}"