Revert Introduce DISTRO_apm patch until I get permission
authorSebastian Spaeth <Sebastian@SSpaeth.de>
Fri, 4 Dec 2009 07:30:46 +0000 (08:30 +0100)
committerSebastian Spaeth <Sebastian@SSpaeth.de>
Fri, 4 Dec 2009 07:30:46 +0000 (08:30 +0100)
* This was committed accidentally
* This reverts commit 49d5f70658ab0386bee5869656d0405a6d416e35.

recipes/ipaq-sleep/ipaq-sleep_0.9.bb
recipes/matchbox2/matchbox-panel-2_svn.bb
recipes/openmoko2/neod_svn.bb
recipes/suspend-desktop/suspend-desktop_1.0.bb
recipes/tasks/task-base.bb

index 6c37b73..24d881d 100644 (file)
@@ -2,9 +2,8 @@ DESCRIPTION = "Automatic sleep/suspend control daemon"
 SECTION = "x11/base"
 LICENSE = "GPL"
 DEPENDS = "apmd virtual/xserver libxext virtual/libx11 libxau xscrnsaverh libxss"
-DISTRO_apm ?= "apm"
-RDEPENDS = "${DISTRO_apm}"
-PR = "r7"
+RDEPENDS = "apm"
+PR = "r6"
 
 inherit gpe pkgconfig
 
index 9d1781b..a2a807f 100644 (file)
@@ -1,15 +1,13 @@
 DESCRIPTION = "matchbox-panel-2 is a lightweight dock (system tray) application based on Gtk+"
 LICENSE = "GPLv2"
 SECTION = "x11/panels"
-
-DISTRO_apm ?= "apm"
 DEPENDS = "gtk+ startup-notification dbus dbus-glib matchbox-panel-2-icon-themes"
 DEPENDS += " ${@base_contains("MACHINE_FEATURES", "acpi", "libacpi", "",d)}"
-DEPENDS += " ${@base_contains("MACHINE_FEATURES", "${DISTRO_apm}", "apmd", "",d)}"
+DEPENDS += " ${@base_contains("MACHINE_FEATURES", "apm", "apmd", "",d)}"
 RDEPENDS_${PN} = "matchbox-panel-2-icon-theme"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 PV = "2.0+svnr${SRCPV}"
-PR = "r1"
+PR = "r0"
 
 inherit autotools_stage pkgconfig
 
index 14858a7..aeeee87 100644 (file)
@@ -1,11 +1,9 @@
 DESCRIPTION = "Simple Neo1973 Daemon for Button Handling and Power Management"
 SECTION = "openmoko/daemons"
-
-DISTRO_apm ?= "apm"
 DEPENDS = "gtk+ pulseaudio apmd"
-RDEPENDS = "gpe-scap xrandr alsa-utils-amixer ${DISTRO_apm} dbus"
+RDEPENDS = "gpe-scap xrandr alsa-utils-amixer apm dbus"
 PV = "0.1.0+svnr${SRCPV}"
-PR = "r7"
+PR = "r6"
 
 inherit openmoko2 gconf
 
index 8fcdfea..fa9efba 100644 (file)
@@ -3,11 +3,10 @@ PRIORITY    = "optional"
 DESCRIPTION = "Suspend feature for the application launcher menu."
 LICENSE     = "GPL"
 
-PR          = "r2"
+PR          = "r1"
 
-DISTRO-apm ?= "apm"
 RDEPENDS    = "gpe-conf"
-RRECOMMENDS = "${DISTRO_apm}"
+RRECOMMENDS = "apm"
 
 PACKAGES    = "${PN}"
 PACKAGE_ARCH = "all"
index 6aad873..ed561b8 100644 (file)
@@ -1,5 +1,5 @@
 DESCRIPTION = "Merge machine and distro options to create a basic machine task/package"
-PR = "r87"
+PR = "r86"
 
 inherit task
 
@@ -60,9 +60,6 @@ HOTPLUG ?= "${@base_contains("MACHINE_FEATURES", "kernel24",  "linux-hotplug",""
 #
 DISTRO_SSH_DAEMON ?= "dropbear"
 
-# Distro can override apm provider
-DISTRO_apm ?= "apm"
-
 #
 # bluetooth manager
 #
@@ -193,7 +190,7 @@ RDEPENDS_task-base-acpi = "\
     acpid"
 
 RDEPENDS_task-base-apm = "\
-    "${DISTRO_apm}" \
+    apm \
     apmd \
     ${@base_contains('MACHINE_FEATURES', 'kernel24', 'network-suspend-scripts', '',d)}"