libcdio: add 0.81
authorKoen Kooi <koen@openembedded.org>
Sun, 17 Jan 2010 16:13:46 +0000 (17:13 +0100)
committerKoen Kooi <koen@openembedded.org>
Mon, 18 Jan 2010 04:25:51 +0000 (05:25 +0100)
recipes/xbmc/libcdio_0.81.bb [new file with mode: 0644]

diff --git a/recipes/xbmc/libcdio_0.81.bb b/recipes/xbmc/libcdio_0.81.bb
new file mode 100644 (file)
index 0000000..e900336
--- /dev/null
@@ -0,0 +1,18 @@
+DESCRIPTION = "The GNU Compact Disc Input and Control library (libcdio) contains a library for CD-ROM and CD image access."
+LICENSE = "GPL"
+
+SRC_URI = "http://ftp.gnu.org/gnu/libcdio/libcdio-${PV}.tar.gz"
+
+inherit autotools
+
+EXTRA_OECONF = " ac_cv_member_struct_tm_tm_gmtoff=no"
+
+FILES_${PN} = "${bindir}/*"
+
+python populate_packages_prepend () {
+       glibdir = bb.data.expand('${libdir}', d)
+       do_split_packages(d, glibdir, '^lib(.*)\.so\.*', 'lib%s', 'gstreamer %s library', extra_depends='', allow_links=True)
+}
+
+
+