omap3-mkcard.bb : add a recipe for mkcard.sh so we can install on targets
authorGraeme Gregory <dp@xora.org.uk>
Fri, 12 Feb 2010 22:55:09 +0000 (22:55 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Fri, 12 Feb 2010 22:55:51 +0000 (22:55 +0000)
recipes/angstrom/omap3-mkcard.bb [new file with mode: 0644]
recipes/angstrom/omap3-mkcard/omap3-mkcard.sh [new symlink]

diff --git a/recipes/angstrom/omap3-mkcard.bb b/recipes/angstrom/omap3-mkcard.bb
new file mode 100644 (file)
index 0000000..c7a1a3e
--- /dev/null
@@ -0,0 +1,11 @@
+DESCRIPTION="Format a card for omap3 booting"
+SRC_URI = "file://omap3-mkcard.sh"
+
+do_install() {
+       install -d ${D}${bindir}/
+       install -m 755 ${WORKDIR}/omap3-mkcard.sh ${D}${bindir}/
+}
+
+PACKAGE_ARCH_${PN} = "all"
+RDEPENDS_${PN} = "bc dosfstools e2fsprogs-mke2fs util-linux-ng util-linux-ng-sfdisk"
+
diff --git a/recipes/angstrom/omap3-mkcard/omap3-mkcard.sh b/recipes/angstrom/omap3-mkcard/omap3-mkcard.sh
new file mode 120000 (symlink)
index 0000000..b8c8a70
--- /dev/null
@@ -0,0 +1 @@
+../../../contrib/angstrom/omap3-mkcard.sh
\ No newline at end of file