aceofpenguins: new recipe from SHR
authorMartin Jansa <Martin.Jansa@gmail.com>
Wed, 18 Nov 2009 07:35:49 +0000 (08:35 +0100)
committerMartin Jansa <Martin.Jansa@gmail.com>
Wed, 18 Nov 2009 08:57:05 +0000 (09:57 +0100)
recipes/aceofpenguins/aceofpenguins-launcher_0.3.bb [new file with mode: 0644]
recipes/aceofpenguins/aceofpenguins_1.2.bb [new file with mode: 0644]
recipes/aceofpenguins/files/gcc4.patch [new file with mode: 0644]

diff --git a/recipes/aceofpenguins/aceofpenguins-launcher_0.3.bb b/recipes/aceofpenguins/aceofpenguins-launcher_0.3.bb
new file mode 100644 (file)
index 0000000..265b8c6
--- /dev/null
@@ -0,0 +1,21 @@
+DESCRIPTION = "EFL launcher for ace-of-penguins"
+HOMEPAGE = "http://shr-project.org"
+SHR_RELEASE ?= "shr"
+LICENSE ?= "GPL"
+DEPENDS = "python-native python-elementary"
+RDEPENDS = "aceofpenguins"
+SECTION = "x11/application"
+
+PACKAGE_ARCH = "all"
+
+PR = "r0"
+
+inherit setuptools
+
+SRC_URI = "http://downloads.vdm-design.de/aceofpenguins-launcher-${PV}.tar.gz"
+
+S = "${WORKDIR}/aceofpenguins-launcher"
+
+FILES_${PN} += "${prefix}/share/pixmaps"
+FILES_${PN} += "${prefix}/share/applications"
+
diff --git a/recipes/aceofpenguins/aceofpenguins_1.2.bb b/recipes/aceofpenguins/aceofpenguins_1.2.bb
new file mode 100644 (file)
index 0000000..9410eb9
--- /dev/null
@@ -0,0 +1,18 @@
+DESCRIPTION = "The Ace of Penguins is a set of Unix/X solitaire games based on the ones available for Windows(tm) but with a number of enhancements that my wife says make my versions better :-) \
+The latest version includes clones of freecell, golf, mastermind, merlin, minesweeper, pegged, solitaire, taipei (with editor!), and thornq (by Martin Thornquist)."
+AUTHOR = "dj@delorie.com"
+HOMEPAGE = "http://www.delorie.com/store/ace/"
+SECTION = "games"
+DEPENDS = "libpng zlib libxpm"
+PR = "r1"
+
+SRC_URI = "\
+  http://www.delorie.com/store/ace/ace-${PV}.tar.gz\
+  file://gcc4.patch;patch=1\
+"
+S = "${WORKDIR}/ace-${PV}"
+
+inherit autotools
+
+# Workaround QA issue
+TARGET_CC_ARCH += "${LDFLAGS}"
\ No newline at end of file
diff --git a/recipes/aceofpenguins/files/gcc4.patch b/recipes/aceofpenguins/files/gcc4.patch
new file mode 100644 (file)
index 0000000..431c44e
--- /dev/null
@@ -0,0 +1,23 @@
+--- ace-of-penguins-1.2.orig/games/golf.c
++++ ace-of-penguins-1.2/games/golf.c
+@@ -31,7 +31,7 @@
+ Stack *deck, *discard, *stacks[7];
+-static int table_width, table_height;
++int table_width, table_height;
+ int supress_arrows = 0;
+
+--- ace-of-penguins-1.2.orig/games/solitaire.c
++++ ace-of-penguins-1.2/games/solitaire.c
+@@ -337,7 +337,7 @@
+   return something_moved;
+ }
+-static void
++void
+ check_for_end_of_game()
+ {
+   while (auto_move());
+