mplayer_0.0+1.0rc1.bb : add latest version of mplayer, fixing versioning
authorGraeme Gregory <dp@xora.org.uk>
Wed, 6 Dec 2006 09:35:40 +0000 (09:35 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Wed, 6 Dec 2006 09:35:40 +0000 (09:35 +0000)
to meet OE policy.
A couple of patches have been rediffed and two Makefile patches dropped as
what they did is now in the Makefiles in question.

packages/mplayer/files/Makefile.patch
packages/mplayer/files/libmpcodecs-ogg-include.patch [deleted file]
packages/mplayer/files/libmpdemux-ogg-include.patch [deleted file]
packages/mplayer/files/w100-mplayer.patch
packages/mplayer/mplayer_0.0+1.0rc1.bb [moved from packages/mplayer/mplayer_1.0pre8.bb with 91% similarity]

index b9b6849..f0464b9 100644 (file)
@@ -1,15 +1,13 @@
-Index: MPlayer-1.0pre8/Makefile
+Index: MPlayer-1.0rc1/Makefile
 ===================================================================
---- MPlayer-1.0pre8.orig/Makefile
-+++ MPlayer-1.0pre8/Makefile
-@@ -438,8 +438,8 @@ codecs2html: mp_msg.o
-       $(CC) -DCODECS2HTML codec-cfg.c mp_msg.o -o $@
+--- MPlayer-1.0rc1.orig/Makefile
++++ MPlayer-1.0rc1/Makefile
+@@ -399,7 +399,7 @@ osdep/mplayer-rc.o: osdep/mplayer.rc
+       windres -o $@ osdep/mplayer.rc
  
- $(PRG_CFG): codec-cfg.c codec-cfg.h help_mp.h
--      $(HOST_CC) $(HOST_CFLAGS) -I. codec-cfg.c -o $(PRG_CFG) \
--      -DCODECS2HTML $(EXTRA_LIB) $(EXTRA_INC)
-+      $(BUILD_CC) -Ilibmpdemux -Iloader -Ilibvo -I. codec-cfg.c -o $(PRG_CFG) \
-+      -DCODECS2HTML 
+ codec-cfg: codec-cfg.c codec-cfg.h help_mp.h
+-      $(HOST_CC) -I. -DCODECS2HTML codec-cfg.c -o $@
++      $(BUILD_CC) -I. -DCODECS2HTML codec-cfg.c -o $@
  
- install: $(ALL_PRG)
- ifeq ($(VIDIX),yes)
+ codecs.conf.h: codec-cfg etc/codecs.conf
+       ./codec-cfg ./etc/codecs.conf > $@
diff --git a/packages/mplayer/files/libmpcodecs-ogg-include.patch b/packages/mplayer/files/libmpcodecs-ogg-include.patch
deleted file mode 100644 (file)
index 619c4b0..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- MPlayer-1.0pre8/libmpcodecs/Makefile.orig  2006-06-30 23:26:33.000000000 +0100
-+++ MPlayer-1.0pre8/libmpcodecs/Makefile       2006-06-30 23:28:52.000000000 +0100
-@@ -267,8 +267,8 @@
- SRCS2=$(ENCODER_SRCS)
- OBJS2=$(SRCS2:.c=.o)
--CFLAGS  = $(OPTFLAGS) \
--          -I. -I.. \
-+CFLAGS  = -I.. $(OPTFLAGS) \
-+          -I. \
-           -Inative \
-           -I../libmpdemux \
-           -I../loader \
diff --git a/packages/mplayer/files/libmpdemux-ogg-include.patch b/packages/mplayer/files/libmpdemux-ogg-include.patch
deleted file mode 100644 (file)
index 541f4a0..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- MPlayer-1.0pre8/libmpdemux/Makefile.orig   2006-06-30 23:26:49.000000000 +0100
-+++ MPlayer-1.0pre8/libmpdemux/Makefile        2006-06-30 23:27:10.000000000 +0100
-@@ -156,8 +156,8 @@
- OBJS  = $(SRCS:.c=.o)
- OBJS   += $(CPLUSPLUSSRCS:.cpp=.o)
--INCLUDE = -I.. -I../loader $(CSS_INC) $(EXTRA_INC) $(LIBAV_INC)
--CFLAGS  = $(OPTFLAGS) $(INCLUDE) $(XMMS_CFLAGS) $(CDPARANOIA_INC) $(DVB_INC)
-+INCLUDE = -I../loader $(CSS_INC) $(EXTRA_INC) $(LIBAV_INC)
-+CFLAGS  = -I.. $(OPTFLAGS) $(INCLUDE) $(XMMS_CFLAGS) $(CDPARANOIA_INC) $(DVB_INC)
- CPLUSPLUSFLAGS  = $(CFLAGS) $(CPLUSPLUSINCLUDE) -D__STDC_LIMIT_MACROS
- CPLUSPLUS = $(CC)
index 4bed632..8ce37d0 100644 (file)
@@ -1,6 +1,8 @@
---- mplayer_20060519/mplayer.c.orig    2006-05-30 12:31:01.000000000 +0100
-+++ mplayer_20060519/mplayer.c 2006-05-30 12:33:41.000000000 +0100
-@@ -628,6 +628,18 @@
+Index: MPlayer-1.0rc1/mplayer.c
+===================================================================
+--- MPlayer-1.0rc1.orig/mplayer.c
++++ MPlayer-1.0rc1/mplayer.c
+@@ -807,6 +807,17 @@ static void exit_sighandler(int x){
    exit_player(NULL);
  }
  
 +  }
 +}
 +
-+
- //extern void write_avi_header_1(FILE *f,int fcc,float fps,int width,int height);
  extern void mp_input_register_options(m_config_t* cfg);
-@@ -2732,6 +2744,9 @@
+ #include "mixer.h"
+@@ -3216,6 +3227,9 @@ current_module = NULL;
  #endif
  #endif
  
similarity index 91%
rename from packages/mplayer/mplayer_1.0pre8.bb
rename to packages/mplayer/mplayer_0.0+1.0rc1.bb
index de5fa87..f91a06d 100644 (file)
@@ -5,7 +5,7 @@ HOMEPAGE = "http://www.mplayerhq.hu/"
 DEPENDS = "virtual/libsdl libmad zlib libpng jpeg liba52 freetype fontconfig alsa-lib lzo ncurses lame"
 RDEPENDS = "mplayer-common"
 LICENSE = "GPL"
-SRC_URI = "http://www1.mplayerhq.hu/MPlayer/releases/MPlayer-${PV}.tar.bz2 \
+SRC_URI = "http://www1.mplayerhq.hu/MPlayer/releases/MPlayer-1.0rc1.tar.bz2 \
            file://vo_w100.c \
            file://vo_w100_api.h \
            file://vo_w100_fb.h \
@@ -14,8 +14,6 @@ SRC_URI = "http://www1.mplayerhq.hu/MPlayer/releases/MPlayer-${PV}.tar.bz2 \
            file://w100-Makefile.patch;patch=1 \
            file://w100-video_out.patch;patch=1 \
            file://w100-mplayer.patch;patch=1 \
-           file://libmpdemux-ogg-include.patch;patch=1 \
-           file://libmpcodecs-ogg-include.patch;patch=1 \
            file://pld-onlyarm5.patch;patch=1 \
            ${SOURCEFORGE_MIRROR}/libw100/mplayer-imageon.patch;patch=1 \
            file://imageon-video_out.patch;patch=1"
@@ -29,7 +27,7 @@ PARALLEL_MAKE = ""
 DEPENDS_append_c7x0 = " sharp-aticore-oss libw100 "
 DEPENDS_append_hx4700 = " libw100 "
 
-S = "${WORKDIR}/MPlayer-${PV}"
+S = "${WORKDIR}/MPlayer-1.0rc1"
 
 PACKAGES =+ "mencoder"
 
@@ -53,7 +51,6 @@ EXTRA_OECONF = " \
         --disable-vm \
         --disable-xf86keysym \
        --disable-tv \
-        --disable-tv-v4l \
         --disable-tv-v4l2 \
         --disable-tv-bsdbt848 \
        --enable-rtc \
@@ -82,14 +79,11 @@ EXTRA_OECONF = " \
         --disable-libcdio \
         --enable-liblzo \
        --disable-win32 \
-        --disable-dshow \
         --disable-qtx \
         --disable-xanim \
         --disable-real \
         --disable-xvid \
         --disable-x264 \
-        --disable-divx4linux \
-        --disable-opendivx \
         \
         --disable-libavutil_so \
         --disable-libavcodec_so \
@@ -101,7 +95,6 @@ EXTRA_OECONF = " \
         \
         --disable-speex \
         --disable-theora \
-        --disable-external-faad \
         --disable-faac \
         --disable-ladspa \
         --disable-libdv \
@@ -117,8 +110,6 @@ EXTRA_OECONF = " \
         --disable-amr_nb-fixed \
         --disable-amr_wb \
        \
-        --disable-internal-vidix \
-        --disable-external-vidix \
         --disable-gl \
         --disable-dga \
         --disable-vesa \