net-snmp: add recipe for perl bindings
authorJan Lübbe <jluebbe@debian.org>
Wed, 9 Sep 2009 13:57:50 +0000 (13:57 +0000)
committerJan Lübbe <jluebbe@debian.org>
Fri, 18 Sep 2009 08:04:37 +0000 (08:04 +0000)
It seems hard to convince net-snmp's build system to crossbuild the perl
bindings, so i use a new recipe.

recipes/net-snmp/libsnmp-perl_5.4.2.1.bb [new file with mode: 0644]
recipes/net-snmp/libsnmp-perl_svn.bb [new file with mode: 0644]

diff --git a/recipes/net-snmp/libsnmp-perl_5.4.2.1.bb b/recipes/net-snmp/libsnmp-perl_5.4.2.1.bb
new file mode 100644 (file)
index 0000000..1352601
--- /dev/null
@@ -0,0 +1,13 @@
+DESCRIPTION = "Perl module from net-snmp"
+SECTION = "libs"
+LICENSE = "BSD"
+DEPENDS = "net-snmp"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/net-snmp/net-snmp-${PV}.tar.gz"
+
+S = "${WORKDIR}/net-snmp-${PV}/perl"
+
+inherit cpan
+
+EXTRA_CPANFLAGS = "-NET-SNMP-CONFIG=\"sh ${STAGING_BINDIR}/net-snmp-config\""
diff --git a/recipes/net-snmp/libsnmp-perl_svn.bb b/recipes/net-snmp/libsnmp-perl_svn.bb
new file mode 100644 (file)
index 0000000..729a3d9
--- /dev/null
@@ -0,0 +1,13 @@
+DESCRIPTION = "Perl module from net-snmp"
+SECTION = "libs"
+LICENSE = "BSD"
+DEPENDS = "net-snmp"
+PR = "r2"
+
+SRC_URI = "svn://net-snmp.svn.sourceforge.net/svnroot/net-snmp/trunk;rev=17367;module=net-snmp;proto=https"
+
+S = "${WORKDIR}/net-snmp/perl"
+
+inherit cpan
+
+EXTRA_CPANFLAGS = "-NET-SNMP-CONFIG=${STAGING_BINDIR}/net-snmp-config -NET-SNMP-IN-SOURCE=false"