pthsem: new recipe, version 2.0.7
authorDirk Opfer <dirk@do13.de>
Wed, 22 Apr 2009 08:23:41 +0000 (10:23 +0200)
committerDirk Opfer <dirk@do13.de>
Wed, 22 Apr 2009 08:23:41 +0000 (10:23 +0200)
GNU Portable Threads replacement with semaphore support

recipes/pthsem/files/ldflags.patch [new file with mode: 0644]
recipes/pthsem/pthsem_2.0.7.bb [new file with mode: 0644]

diff --git a/recipes/pthsem/files/ldflags.patch b/recipes/pthsem/files/ldflags.patch
new file mode 100644 (file)
index 0000000..74fd60b
--- /dev/null
@@ -0,0 +1,16 @@
+diff -urN pth-2.0.2.orig/Makefile.in pth-2.0.2/Makefile.in
+--- pth-2.0.2.orig/Makefile.in 2004-07-13 10:48:10.000000000 +0000
++++ pth-2.0.2/Makefile.in      2009-04-06 12:12:37.000000000 +0000
+@@ -168,10 +168,10 @@
+ #   build the static and possibly shared libraries
+ libpthsem.la: $(LOBJS)
+-      $(LIBTOOL) --mode=link --quiet $(CC) -o libpthsem.la $(LOBJS) \
++      $(LIBTOOL) --mode=link --quiet $(CC) $(LDFLAGS) -o libpthsem.la $(LOBJS) \
+       -rpath $(libdir) -version-info `$(SHTOOL) version -lc -dlibtool $(_VERSION_FILE)`
+ libpthread.la: pthread.lo $(LOBJS)
+-      $(LIBTOOL) --mode=link --quiet $(CC) -o libpthread.la pthread.lo $(LOBJS) \
++      $(LIBTOOL) --mode=link --quiet $(CC) $(LDFLAGS) -o libpthread.la pthread.lo $(LOBJS) \
+       -rpath $(libdir) -version-info `$(SHTOOL) version -lc -dlibtool $(_VERSION_FILE)`
+ #   build the manual pages
diff --git a/recipes/pthsem/pthsem_2.0.7.bb b/recipes/pthsem/pthsem_2.0.7.bb
new file mode 100644 (file)
index 0000000..30e2f17
--- /dev/null
@@ -0,0 +1,31 @@
+DESCRIPTION = "GNU Portable Threads replacement with semaphore support"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+PR = "r0"
+
+SRC_URI = "https://www.auto.tuwien.ac.at/~mkoegler/pth/pthsem-${PV}.tar.gz \
+           file://ldflags.patch;patch=1 \
+          "
+
+inherit autotools binconfig
+
+do_configure() {
+        gnu-configize
+        oe_runconf
+}
+do_install_prepend() {
+        cp ${S}/pth-config ${S}/pthsem-config
+}
+do_stage() {
+        oe_libinstall -so libpthsem ${STAGING_LIBDIR}
+        install -d ${STAGING_INCDIR}/
+        install -m 0644 ${S}/pth.h ${STAGING_INCDIR}/pthsem.h
+        install -d ${STAGING_BINDIR}/
+        install -d ${STAGING_DATADIR}/aclocal
+        install pth.m4 ${STAGING_DATADIR}/aclocal/pthsem.m4
+}
+
+BINCONFIG_GLOB = "pthsem-config"
+
+PARALLEL_MAKE = ""