libtool: Use more clean way to set ac_cv_path_* variables. Never load libtool.inc...
authorStanislav Brabec <utx@penguin.cz>
Thu, 17 Sep 2009 22:28:27 +0000 (22:28 +0000)
committerutx@penguin.cz <utx@penguin.cz>
Thu, 17 Sep 2009 22:28:27 +0000 (22:28 +0000)
16 files changed:
recipes/libtool/libtool-cross_1.5.10.bb
recipes/libtool/libtool-cross_1.5.22.bb
recipes/libtool/libtool-cross_1.5.24.bb
recipes/libtool/libtool-cross_2.2.4.bb
recipes/libtool/libtool-cross_2.2.6a.bb
recipes/libtool/libtool-native_1.5.10.bb
recipes/libtool/libtool-native_1.5.22.bb
recipes/libtool/libtool-native_1.5.24.bb
recipes/libtool/libtool-native_2.2.4.bb
recipes/libtool/libtool-native_2.2.6a.bb
recipes/libtool/libtool-sdk_1.5.10.bb
recipes/libtool/libtool-sdk_2.2.4.bb
recipes/libtool/libtool-sdk_2.2.6a.bb
recipes/libtool/libtool.inc
recipes/libtool/libtool_2.2.4.bb
recipes/libtool/libtool_2.2.6a.bb

index 256e71c..910ff12 100644 (file)
@@ -1,4 +1,3 @@
-require libtool.inc
 require libtool_${PV}.bb
 
 PR = "${INC_PR}.0"
index 9490311..b0cee4e 100644 (file)
@@ -1,6 +1,5 @@
 DEFAULT_PREFERENCE = "-1"
 
-require libtool.inc
 require libtool_${PV}.bb
 
 PR = "${INC_PR}.0"
index 2a7e4d7..1f85278 100644 (file)
@@ -1,4 +1,3 @@
-require libtool.inc
 require libtool_${PV}.bb
 
 PR = "${INC_PR}.0"
index e2c6bbe..31a67f5 100644 (file)
@@ -1,4 +1,3 @@
-require libtool.inc
 require libtool_${PV}.bb
 PR = "${INC_PR}.0"
 
@@ -22,11 +21,6 @@ prefix = "${STAGING_DIR_NATIVE}${layout_prefix}"
 exec_prefix = "${STAGING_DIR_NATIVE}${layout_exec_prefix}"
 bindir = "${STAGING_BINDIR_NATIVE}"
 
-# skip ac_cv_... setting for cross build: host paths must be used
-do_configure_prepend () {
-       export LIBTOOL_BB_DO_NOT_SET_PATHS=1
-}
-
 do_compile () {
        :
 }
index b26e7cc..23c1682 100644 (file)
@@ -1,4 +1,3 @@
-require libtool.inc
 require libtool_${PV}.bb
 PR = "${INC_PR}.0"
 
@@ -20,11 +19,6 @@ prefix = "${STAGING_DIR_NATIVE}${layout_prefix}"
 exec_prefix = "${STAGING_DIR_NATIVE}${layout_exec_prefix}"
 bindir = "${STAGING_BINDIR_NATIVE}"
 
-# skip ac_cv_... setting for cross build: host paths must be used
-do_configure_prepend () {
-       export LIBTOOL_BB_DO_NOT_SET_PATHS=1
-}
-
 do_compile () {
        :
 }
index 362aea2..76cbb4b 100644 (file)
@@ -1,4 +1,3 @@
-require libtool.inc
 require libtool_${PV}.bb
 
 PR = "${INC_PR}.0"
index 4d660f4..3aadb2b 100644 (file)
@@ -1,6 +1,5 @@
 DEFAULT_PREFERENCE = "-1"
 
-require libtool.inc
 require libtool_${PV}.bb
 
 PR = "${INC_PR}.0"
index 9536881..f767afc 100644 (file)
@@ -1,6 +1,5 @@
 SECTION = "devel"
 
-require libtool.inc
 require libtool_${PV}.bb
 
 PR = "${INC_PR}.0"
index 06564c7..a7ad685 100644 (file)
@@ -1,4 +1,3 @@
-require libtool.inc
 require libtool_${PV}.bb
 PR = "${INC_PR}.0"
 
index e699a2f..082663a 100644 (file)
@@ -1,4 +1,3 @@
-require libtool.inc
 require libtool_${PV}.bb
 PR = "${INC_PR}.0"
 
index 21e408d..ac188bd 100644 (file)
@@ -1,4 +1,3 @@
-require libtool.inc
 require libtool_${PV}.bb
 
 PR = "${INC_PR}.0"
index 0e9ae9b..c934a6e 100644 (file)
@@ -1,4 +1,3 @@
-require libtool.inc
 require libtool_${PV}.bb
 
 PR = "${INC_PR}.0"
@@ -9,11 +8,6 @@ S = "${WORKDIR}/libtool-${PV}"
 
 inherit sdk
 
-# skip ac_cv_... setting for cross build: host paths must be used
-do_configure_prepend () {
-       export LIBTOOL_BB_DO_NOT_SET_PATHS=1
-}
-
 do_install () {
        install -d ${D}${bindir}/
        install -m 0755 libtool ${D}${bindir}/
index 263879b..7e269ef 100644 (file)
@@ -1,4 +1,3 @@
-require libtool.inc
 require libtool_${PV}.bb
 
 PR = "${INC_PR}.0"
@@ -6,11 +5,6 @@ SRC_URI_append = " file://cross_compile.patch;patch=1"
 
 inherit sdk
 
-# skip ac_cv_... setting for cross build: host paths must be used
-do_configure_prepend () {
-       export LIBTOOL_BB_DO_NOT_SET_PATHS=1
-}
-
 do_install () {
        install -d ${D}${bindir}/
        install -m 0755 libtool ${D}${bindir}/
index 9cc7401..838f029 100644 (file)
@@ -6,6 +6,16 @@ HOMEPAGE = "http://www.gnu.org/software/libtool/libtool.html"
 LICENSE = "GPL"
 SECTION = "devel"
 
-INC_PR = "r24"
+INC_PR = "r25"
 
 FILESPATHPKG=. "libtool-${PV}:"
+
+do_configure_prepend () {
+       if ${@['true', 'false'][bb.data.inherits_class('native', d) or bb.data.inherits_class('sdk', d) or (bb.data.getVar('PN', d, 1) == 'libtool-cross')]}
+       then
+               export ac_cv_path_SED="${ac_cv_path_SED=${base_bindir}/sed}"
+               export ac_cv_path_GREP="${ac_cv_path_GREP=${base_bindir}/grep}"
+               export ac_cv_path_EGREP="${ac_cv_path_EGREP=${base_bindir}/grep -E}"
+               export ac_cv_path_FGREP="${ac_cv_path_FGREP=${base_bindir}/grep -F}"
+       fi
+}
index 6de7336..65c2d17 100644 (file)
@@ -14,18 +14,6 @@ inherit autotools
 
 EXTRA_AUTORECONF = "--exclude=libtoolize"
 
-do_configure_prepend () {
-       # Skip this for native build:
-       if test -n "$CONFIG_SITE" ; then
-       if test -z "$LIBTOOL_BB_DO_NOT_SET_PATHS" ; then
-                       export ac_cv_path_SED="${ac_cv_path_SED=/bin/sed}"
-                       export ac_cv_path_GREP="${ac_cv_path_GREP=/bin/grep}"
-                       export ac_cv_path_EGREP="${ac_cv_path_EGREP=/bin/grep -E}"
-                       export ac_cv_path_FGREP="${ac_cv_path_FGREP=/bin/grep -F}"
-               fi
-       fi
-}
-
 do_stage () {
        install -d ${STAGING_INCDIR}/libltdl
        install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/
index c69a937..0595613 100644 (file)
@@ -16,18 +16,6 @@ inherit autotools
 
 EXTRA_AUTORECONF = "--exclude=libtoolize"
 
-do_configure_prepend () {
-       # Skip this for native build:
-       if test -n "$CONFIG_SITE" ; then
-       if test -z "$LIBTOOL_BB_DO_NOT_SET_PATHS" ; then
-                       export ac_cv_path_SED="${ac_cv_path_SED=/bin/sed}"
-                       export ac_cv_path_GREP="${ac_cv_path_GREP=/bin/grep}"
-                       export ac_cv_path_EGREP="${ac_cv_path_EGREP=/bin/grep -E}"
-                       export ac_cv_path_FGREP="${ac_cv_path_FGREP=/bin/grep -F}"
-               fi
-       fi
-}
-
 do_stage () {
        install -d ${STAGING_INCDIR}/libltdl
        install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/