opie-taskbar: compile fix
authorHenning Heinold <heinold@inf.fu-berlin.de>
Tue, 12 Jan 2010 23:11:27 +0000 (00:11 +0100)
committerHenning Heinold <heinold@inf.fu-berlin.de>
Tue, 12 Jan 2010 23:11:27 +0000 (00:11 +0100)
* comment the use of LnkProperties
* maybee opie losses some functionality, but it's better to
  have something working for now
* bump PR

recipes/opie-taskbar/opie-taskbar/launcher.patch [new file with mode: 0644]
recipes/opie-taskbar/opie-taskbar_1.2.4.bb

diff --git a/recipes/opie-taskbar/opie-taskbar/launcher.patch b/recipes/opie-taskbar/opie-taskbar/launcher.patch
new file mode 100644 (file)
index 0000000..e7f90f9
--- /dev/null
@@ -0,0 +1,17 @@
+Index: launcher/launcher.cpp
+===================================================================
+--- launcher.orig/launcher.cpp 2009-12-23 22:29:17.396221157 +0100
++++ launcher/launcher.cpp      2009-12-23 22:31:45.849117517 +0100
+@@ -646,10 +646,10 @@
+     // Not supported: flat is simpler for the user
+     } else {
+ /* ### libqtopia FIXME also moving docLnks... */
+-        LnkProperties prop(appLnk,0 );
++    /*    LnkProperties prop(appLnk,0 );
+         if (QPEApplication::execDialog( &prop )==QDialog::Accepted && tabs->currentView()==tabs->docView()) {
+-        }
++        }*/
+     }
+ }
index aa6db3c..7648747 100644 (file)
@@ -1,5 +1,5 @@
 require ${PN}.inc
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/calibrate \
            ${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/settings/mediummount \
@@ -14,4 +14,5 @@ SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/calibrate \
           file://restart-from-bindir.patch;patch=1 \
            file://server-pro-1.2.4.patch;patch=1 \
           file://firstuse-path.patch;patch=1 \
+           file://launcher.patch;patch=1 \
           "