attr_2.4.44.bb : uclibc needs a -lintl to compile
authorGraeme Gregory <dp@xora.org.uk>
Mon, 1 Mar 2010 10:49:06 +0000 (10:49 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Mon, 1 Mar 2010 10:50:21 +0000 (10:50 +0000)
recipes/udev/attr_2.4.44.bb

index 7cb9217..a20568d 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Commands for Manipulating Filesystem Extended Attributes"
 LICENSE = "GPLv2"
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://mirror.its.uidaho.edu/pub/savannah/attr/attr-${PV}.src.tar.gz"
 
@@ -9,6 +9,8 @@ inherit gettext autotools lib_package
 
 EXTRA_OECONF = " --enable-gettext=yes ac_cv_path_XGETTEXT=${STAGING_BINDIR_NATIVE}/xgettext"
 
+LDFLAGS_append_libc-uclibc += " -lintl"
+
 do_configure_append() {
        # gettext hack
        echo "#define _(str) str" >> ${S}/include/config.h