libgles-omap3-es23: fix init script
authorGrazvydas Ignotas <notasas@gmail.com>
Sun, 12 Oct 2014 16:39:26 +0000 (19:39 +0300)
committerGrazvydas Ignotas <notasas@gmail.com>
Sun, 12 Oct 2014 16:39:26 +0000 (19:39 +0300)
recipes/powervr-drivers/files/rc.pvr
recipes/powervr-drivers/libgles-omap3-es23_4.00.00.01.bb

index 6c12159..3bf2e4f 100755 (executable)
@@ -24,9 +24,17 @@ load_driver()
        fi
 
        if ! lsmod | grep -q pvrsrvkm; then
-               echo pvrsrvkm failed to load
+               echo "pvrsrvkm failed to load"
                exit 1
        fi
+
+       test -e /dev/pvrsrvkm || sleep 1
+       if ! test -e /dev/pvrsrvkm; then
+               echo "pvrsrvkm dev file did not appear"
+               exit 1
+       fi
+
+       chmod 666 /dev/pvrsrvkm
 }
 
 # $1 - full pathname, like /usr/lib/ES5.0/libGLESv2.so.1.4.14.2616
@@ -69,16 +77,6 @@ fbset -vyres $(expr $YRES \* 3)
 
        load_driver
 
-       #pvr_maj=`grep "pvrsrvkm$" /proc/devices | cut -b1,2,3`
-        #bc_maj=`grep "bc" /proc/devices | cut -b1,2,3`
-
-       #if [ -e /dev/pvrsrvkm ] ; then 
-       #       rm -f /dev/pvrsrvkm
-       #fi
-
-       #mknod /dev/pvrsrvkm c $pvr_maj 0 
-       chmod 666 /dev/pvrsrvkm
-
        touch /etc/powervr-esrev
 
        SAVED_ESREVISION="$(cat /etc/powervr-esrev)"
index 0fd0d3b..a41e326 100644 (file)
@@ -6,7 +6,7 @@ ES5LOCATION = "none"
 
 require libgles-omap3.inc
 
-PR = "r1"
+PR = "r2"
 
 SGXPV = "4_00_00_01"
 IMGPV = "1.4.14.2616"
@@ -30,6 +30,8 @@ S = "${WORKDIR}/Graphics_SDK_${SGXPV}"
 # upgrade path
 RCONFLICTS = "libgles-omap3"
 RREPLACES_${PN} = "libgles-omap3"
+RREPLACES_${PN}-dev = "libgles-omap3-dev"
+RREPLACES_${PN}-dbg = "libgles-omap3-dbg"
 RREPLACES_${PN}-rawdemos = "libgles-omap3-rawdemos"
 RREPLACES_${PN}-x11demos = "libgles-omap3-x11demos"
 RREPLACES_${PN}-rawtrainingcourses = "libgles-omap3-rawtrainingcourses"