bootchart-lite: Use mkdir rather than install in postinst.
authorSebastian Spaeth <Sebastian@SSpaeth.de>
Fri, 27 Nov 2009 09:55:03 +0000 (10:55 +0100)
committerSebastian Spaeth <Sebastian@SSpaeth.de>
Fri, 27 Nov 2009 09:55:03 +0000 (10:55 +0100)
* install is part of coreutils which might not be installed.
* As this is a -lite image it might not make sense to pull in coreutils just to create a dir.

Signed-off-by: Sebastian Spaeth <Sebastian@SSpaeth.de>
recipes/bootchart-lite/bootchart-lite_svn.bb

index 2220560..1368c92 100644 (file)
@@ -12,7 +12,7 @@ S = "${WORKDIR}/trunk"
 inherit autotools
 
 pkg_postinst_${PN} () {
-       install -d /etc/bootchart-lite
+       mkdir /etc/bootchart-lite
 }
 
 pkg_postrm_${PN} () {