libgpsbt_0.1.bb : apply patch to remove debian requirement, update staging.
authorGraeme Gregory <dp@xora.org.uk>
Mon, 22 Feb 2010 22:06:37 +0000 (22:06 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Mon, 22 Feb 2010 22:06:37 +0000 (22:06 +0000)
http://wiki.navit-project.org/index.php/Navit_on_OpenEmbedded_for_n810 has
a patch that is required on non debian systems.

recipes/maemo4/libgpsbt/configure-fix-version.patch [new file with mode: 0644]
recipes/maemo4/libgpsbt_0.1.bb

diff --git a/recipes/maemo4/libgpsbt/configure-fix-version.patch b/recipes/maemo4/libgpsbt/configure-fix-version.patch
new file mode 100644 (file)
index 0000000..f628745
--- /dev/null
@@ -0,0 +1,17 @@
+Patch to fix compilation on systems not debian. Taken from
+
+http://wiki.navit-project.org/index.php/Navit_on_OpenEmbedded_for_n810#libgpsmgr_patch
+
+Index: libgpsbt-0.1/configure.ac
+===================================================================
+--- libgpsbt-0.1.orig/configure.ac
++++ libgpsbt-0.1/configure.ac
+@@ -1,6 +1,5 @@
+-AC_INIT(Makefile.am)
+-AM_INIT_AUTOMAKE(libgpsbt, patsubst(esyscmd([dpkg-parsechangelog | sed -n '/^Version: \(.*\)$/ {s//\1/;p}']), [
+-]))
++AC_INIT(Makefile.am, [0.1])
++AM_INIT_AUTOMAKE(libgpsbt, [0.1])
+ AM_CONFIG_HEADER(config.h)
+ AC_ARG_ENABLE(debug, [AC_HELP_STRING([--enable-debug],[Debug (default=no)])])
index 2b2c0a1..8293f35 100644 (file)
@@ -1,19 +1,15 @@
 LICENSE = "nokia"
 
-PR = "r1"
+PR = "r2"
 
 DEPENDS = "libgpsmgr dbus"
 
 # This is proprietary software in Chinook, so we have to stay with the last released
 # free version.
-SRC_URI = "http://repository.maemo.org/pool/bora/free/source/${PN}_${PV}-18.tar.gz"
+SRC_URI = "http://repository.maemo.org/pool/bora/free/source/${PN}_${PV}-18.tar.gz \
+           file://configure-fix-version.patch;patch=1"
 
-inherit autotools pkgconfig
+inherit autotools
 
 TARGET_CC_ARCH += "${LDFLAGS}"
 
-do_stage() {
-        autotools_stage_all
-}
-
-