abuse: update to 0.7.1,fix license,compilation(host libdir),and sdl install
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Sat, 26 Mar 2011 21:08:53 +0000 (22:08 +0100)
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Sat, 26 Mar 2011 23:58:41 +0000 (00:58 +0100)
Without the sdl install fix() we have:
| install: cannot stat `.../work/armv7a-angstrom-linux-gnueabi/abuse-0.7.0-r1/abuse.png': No such file or directory

Without the patch -L/usr/lib was passed to the linking flags and it failed at linking.
And if we didn't set the xorg library path we had -L alone in the linking flags which made it fail
  too

Finally The license is assumed to be GPLv2,becase of COPYING.
Altough no headers were present in the source files.

Note that no data are included yet(it could be included in some
  future improvements)

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
recipes/abuse/abuse-0.7.1/no-host-libdir.patch [new file with mode: 0644]
recipes/abuse/abuse_0.7.0.bb [deleted file]
recipes/abuse/abuse_0.7.1.bb [new file with mode: 0644]

diff --git a/recipes/abuse/abuse-0.7.1/no-host-libdir.patch b/recipes/abuse/abuse-0.7.1/no-host-libdir.patch
new file mode 100644 (file)
index 0000000..f19d4a3
--- /dev/null
@@ -0,0 +1,13 @@
+Index: abuse-0.7.1/configure.ac
+===================================================================
+--- abuse-0.7.1.orig/configure.ac      2011-03-26 22:49:26.011146080 +0100
++++ abuse-0.7.1/configure.ac   2011-03-26 22:49:51.831146086 +0100
+@@ -37,7 +37,7 @@
+ AM_PATH_SDL($SDL_VERSION, :,
+     AC_MSG_ERROR([*** SDL version $SDL_VERSION or above not found!]))
+ CFLAGS="$CFLAGS $SDL_CFLAGS"
+-LIBS="$LIBS $SDL_LIBS $X_LIBS -L/usr/lib"
++LIBS="$LIBS $SDL_LIBS $X_LIBS"
+ # Optimizations
+ CPPFLAGS="${CPPFLAGS} -g -O2 -fno-strength-reduce -fomit-frame-pointer"
diff --git a/recipes/abuse/abuse_0.7.0.bb b/recipes/abuse/abuse_0.7.0.bb
deleted file mode 100644 (file)
index 9c64c43..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-DESCRIPTION = "Abuse-SDL is a port of Abuse by Crack Dot Com to Linux - SDL edition."
-SECTION = "games"
-LICENSE = "GPL"
-APPNAME = "abuse.sdl"
-
-SRC_URI = "http://www.labyrinth.net.au/~trandor/abuse/files/abuse_sdl-${PV}.tar.bz2"
-S = "${WORKDIR}/abuse_sdl-${PV}"
-
-inherit autotools sdl
-
-FILES_${PN} += "${datadir}/games"
-
-SRC_URI[md5sum] = "59ea4498886642aa975f04233cc92558"
-SRC_URI[sha256sum] = "bda8a3c42733853444e1d4bee16e85990b78c2eaafc4b26e0769be2e14dab931"
diff --git a/recipes/abuse/abuse_0.7.1.bb b/recipes/abuse/abuse_0.7.1.bb
new file mode 100644 (file)
index 0000000..aaa411c
--- /dev/null
@@ -0,0 +1,20 @@
+DESCRIPTION = "Abuse-SDL is a port of Abuse by Crack Dot Com to Linux - SDL edition."
+SECTION = "games"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://abuse.zoy.org/"
+APPIMAGE = "${S}/${PN}.png"
+
+PR="r0"
+
+inherit autotools sdl
+
+SRC_URI = "http://abuse.zoy.org/raw-attachment/wiki/Downloads/${P}.tar.gz \
+           file://no-host-libdir.patch;apply=yes \
+          "
+
+EXTRA_OECONF = " --x-libraries=${STAGING_LIBDIR}"
+
+FILES_${PN} += "${datadir}/games"
+
+SRC_URI[md5sum] = "439b607f291560a8f9698a2f09cffa63"
+SRC_URI[sha256sum] = "1516a19efc1b89715a8549109a0d87b71502d94fd8b782942e335b6782a1dd57"