klibc: reorganize recipes and patches (use FILESPATHPKG)
authorAndrea Adami <andrea.adami@gmail.com>
Thu, 6 Aug 2009 22:50:18 +0000 (00:50 +0200)
committerAndrea Adami <andrea.adami@gmail.com>
Thu, 6 Aug 2009 22:50:18 +0000 (00:50 +0200)
12 files changed:
recipes/klibc/klibc-1.5.15/fstype-sane-vfat-and-jffs2-for-1.5.patch [moved from recipes/klibc/files/fstype-sane-vfat-and-jffs2-for-1.5.patch with 100% similarity]
recipes/klibc/klibc-1.5.15/modprobe.patch [moved from recipes/klibc/files/modprobe.patch with 100% similarity]
recipes/klibc/klibc-1.5.15/staging.patch [moved from recipes/klibc/files/staging.patch with 100% similarity]
recipes/klibc/klibc-1.5.15/wc.patch [moved from recipes/klibc/files/wc.patch with 100% similarity]
recipes/klibc/klibc-common.inc
recipes/klibc/klibc-common_1.5.15.inc [deleted file]
recipes/klibc/klibc-utils-static_1.5.15.bb
recipes/klibc/klibc-utils-static_1.5.bb
recipes/klibc/klibc_1.5.15.bb
recipes/klibc/klibc_1.5.15.inc
recipes/klibc/klibc_1.5.bb
recipes/klibc/klibc_1.5.inc [moved from recipes/klibc/klibc.inc with 100% similarity]

index ff67450..b66bc61 100644 (file)
@@ -4,13 +4,15 @@ DESCRIPTION = "klibc is intended to be a minimalistic libc subset for \
 use with initramfs.  It is deliberately written for small size, \
 minimal entaglement, and portability, not speed."
 LICENSE = "BSD-ADV"
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/libs/klibc/Stable/klibc-${PV}.tar.bz2 \
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/libs/klibc/${KLIBC_FETCHDIR}/klibc-${PV}.tar.bz2 \
           file://fstype-sane-vfat-and-jffs2-for-1.5.patch;patch=1 \
           file://modprobe.patch;patch=1 \
           file://losetup.patch;patch=1 \
           file://dash_readopt.patch;patch=1 \
           file://wc.patch;patch=1 \
           "
+
 S = "${WORKDIR}/klibc-${PV}"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
diff --git a/recipes/klibc/klibc-common_1.5.15.inc b/recipes/klibc/klibc-common_1.5.15.inc
deleted file mode 100644 (file)
index 58ed99a..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-DEPENDS = "virtual/kernel perl-native"
-SECTION = "libs"
-DESCRIPTION = "klibc is intended to be a minimalistic libc subset for \
-use with initramfs.  It is deliberately written for small size, \
-minimal entaglement, and portability, not speed."
-LICENSE = "BSD-ADV"
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/libs/klibc/Testing/klibc-${PV}.tar.bz2 \
-          file://fstype-sane-vfat-and-jffs2-for-1.5.patch;patch=1 \
-          file://modprobe.patch;patch=1 \
-          file://losetup.patch;patch=1 \
-          file://dash_readopt.patch;patch=1 \
-          file://wc.patch;patch=1 \
-          "
-S = "${WORKDIR}/klibc-${PV}"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-KLIBC_ARCH = '${TARGET_ARCH}'
-KLIBC_ARCH_armeb = 'arm'
-KLIBC_ARCH_mipsel = 'mips'
-KLIBC_ARCH_x86 = 'i386'
-KLIBC_ARCH_i486 = 'i386'
-KLIBC_ARCH_i586 = 'i386'
-KLIBC_ARCH_i686 = 'i386'
-KLIBC_ARCH_pentium = 'i386'
-
-# the klibc code contains ARM instructions (for ARM), this
-# could be fixed, but for the moment:
-ARM_INSTRUCTION_SET = "arm"
-
-SRC_URI_append_linux-gnueabi = "file://klibc-config-eabi.patch;patch=1 \
-                               "
-SRC_URI_append_linux-uclibcgnueabi = "file://klibc-config-eabi.patch;patch=1 \
-                                     "
-
-EXTRA_OEMAKE = "'KLIBCARCH=${KLIBC_ARCH}' \
-                'CROSS_COMPILE=${TARGET_PREFIX}' \
-                "
-
-do_configure () {
-       ln -sf ${STAGING_KERNEL_DIR} linux
-}
-
index 5717886..3fff9b8 100644 (file)
@@ -1,7 +1,10 @@
-require klibc-common_1.5.15.inc
+require klibc-common.inc
 
 PR = "r1"
 
+KLIBC_FETCHDIR = "Testing"
+FILESPATHPKG =. "klibc-${PV}:"
+
 # We only want the static utils. klibc build both. So we install only what we want.
 do_install() {
         install -d ${D}${base_bindir}
index c89def5..a4e31de 100644 (file)
@@ -2,6 +2,9 @@ require klibc-common.inc
 
 PR = "r12"
 
+KLIBC_FETCHDIR = "Stable"
+FILESPATHPKG =. "klibc-${PV}:"
+
 # We only want the static utils. klibc build both. So we install only what we want.                            
 do_install() {
         install -d ${D}${base_bindir}
index aae3e60..e665874 100644 (file)
@@ -1,2 +1,4 @@
 require klibc_1.5.15.inc
 PR = "r1"
+
+KLIBC_FETCHDIR = "Testing"
index a9cd2f3..e8967f5 100644 (file)
@@ -1,4 +1,4 @@
-require klibc-common_1.5.15.inc
+require klibc-common.inc
 
 SRC_URI += "file://staging.patch;patch=1 \
            file://klibc_kexecsyscall.patch;patch=1 \
index a607aa8..3dd4d64 100644 (file)
@@ -1,2 +1,4 @@
-require klibc.inc
+require klibc_1.5.inc
 PR = "r9"
+
+KLIBC_FETCHDIR = "Stable"