fso-specs: catch up with upstream changes and set proper packaging ARCH
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>
Sun, 28 Mar 2010 16:32:32 +0000 (18:32 +0200)
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>
Sun, 28 Mar 2010 16:50:21 +0000 (18:50 +0200)
recipes/freesmartphone/fso-specs_git.bb

index 932feba..73c6c0b 100644 (file)
@@ -1,22 +1,20 @@
-DESCRIPTIONS = "API Specification for freesmartphone.org"
-AUTHOR = "Michael 'Mickey' Lauer"
+DESCRIPTIONS = "freesmartphone.org DBus API files"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
 HOMEPAGE = "http://docs.freesmartphone.org"
 LICENSE = "BSD"
 DEPENDS = "libxslt-native"
 SECTION = "devel/specifications"
 PV = "0.5.0-gitr${SRCREV}"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "${FREESMARTPHONE_GIT}/specs.git;protocol=git;branch=master"
 S = "${WORKDIR}/git"
 
-do_compile() {
-       make xml
-}
+inherit autotools pkgconfig
 
-do_stage() {
-       install -d "${STAGING_DATADIR}/fso-specs"
-       install -m 0644 xml/* "${STAGING_DATADIR}/fso-specs"
-}
+FILES_${PN}-dev += "${datadir}/freesmartphone/xml"
+PACKAGE_ARCH = "all"
 
-FILE_${PN}-dev += "${datadir}/fso-specs"
+do_compile_append() {
+       sed -i -e s,\$\{datarootdir\},${STAGING_DATADIR},g *.pc
+}