php_5.2.11.bb : add --enable-mbstring site/arm-common : add magic value for mbstring...
authorGraeme Gregory <gg@slimlogic.co.uk>
Thu, 10 Dec 2009 02:33:29 +0000 (19:33 -0700)
committerGraeme Gregory <dp@xora.org.uk>
Thu, 10 Dec 2009 02:34:56 +0000 (02:34 +0000)
This enables UTF-8 support in OE php

recipes/php/php_5.2.11.bb
site/arm-common

index 06a9fe2..d4fd985 100644 (file)
@@ -2,7 +2,7 @@ require php.inc
 
 DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native mysql"
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI += "file://pear-makefile.patch;patch=1 \
             "
@@ -10,19 +10,20 @@ export THREADS="pthread"
 export LIBS=" -lpthread "
 
 EXTRA_OECONF = "    --without-iconv \
-                   --enable-discard-path \
-                   --enable-sockets \
-                   --enable-shared \
+                    --enable-mbstring \
+                    --enable-discard-path \
+                    --enable-sockets \
+                    --enable-shared \
                     --enable-pcntl \
-                   --enable-memory-limit \
-                   --enable-wddx \
+                    --enable-memory-limit \
+                    --enable-wddx \
                     --enable-embedded-mysqli \
                     --enable-magic-quotes \
-                   --enable-fastcgi \
-                   --with-zlib --with-zlib-dir=${STAGING_LIBDIR}/.. \
+                    --enable-fastcgi \
+                    --with-zlib --with-zlib-dir=${STAGING_LIBDIR}/.. \
                     --with-libxml-dir=${STAGING_BINDIR_CROSS} \
                     --with-mysql="${STAGING_DIR_TARGET}${layout_exec_prefix}" \
-#                    --with-mysqli = "${STAGING_BINDIR_NATIVE}/mysql_config" \
+#                   --with-mysqli = "${STAGING_BINDIR_NATIVE}/mysql_config" \
                     --without-pdo-sqlite \
                "
 
index b5cf8c2..20de8c5 100644 (file)
@@ -164,6 +164,7 @@ ac_cv_func_getaddrinfo=${ac_cv_func_getaddrinfo=yes}
 ac_cv_pread=${ac_cv_pread=no}
 ac_cv_pwrite=${ac_cv_pwrite=no}
 php_cv_lib_cookie_io_functions_use_off64_t=${php_cv_lib_cookie_io_functions_use_off64_t=yes}
+cv_php_mbstring_stdarg=${cv_php_mbstring_stdarg=yes}
 
 # rsync
 rsync_cv_HAVE_BROKEN_LARGEFILE=${rsync_cv_HAVE_BROKEN_LARGEFILE=no}