libframeworkd-phonegui*: Abstraction libs for fso and efl (from SHR)
authorStefan Schmidt <stefan@datenfreihafen.org>
Thu, 17 Sep 2009 21:21:29 +0000 (21:21 +0000)
committerStefan Schmidt <stefan@datenfreihafen.org>
Thu, 17 Sep 2009 21:24:30 +0000 (21:24 +0000)
recipes/shr/libframeworkd-phonegui-efl2_git.bb [new file with mode: 0644]
recipes/shr/libframeworkd-phonegui-efl_git.bb [new file with mode: 0644]
recipes/shr/libframeworkd-phonegui_git.bb [new file with mode: 0644]

diff --git a/recipes/shr/libframeworkd-phonegui-efl2_git.bb b/recipes/shr/libframeworkd-phonegui-efl2_git.bb
new file mode 100644 (file)
index 0000000..207658f
--- /dev/null
@@ -0,0 +1,18 @@
+DESCRIPTION = "frameworkd EFL phonegui 2"
+SECTION = "e/apps"
+DEPENDS += " dbus-glib libframeworkd-glib libframeworkd-phonegui etk evas ecore edje edje-native elementary"
+PV = "0.0.1+gitr${SRCREV}"
+PR = "r1"
+
+SRC_URI = "git://shr.bearstech.com/repo/libframeworkd-phonegui-efl2.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
+
+inherit pkgconfig autotools autotools_stage
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+
+do_configure_prepend() {
+        autopoint --force
+}
+
diff --git a/recipes/shr/libframeworkd-phonegui-efl_git.bb b/recipes/shr/libframeworkd-phonegui-efl_git.bb
new file mode 100644 (file)
index 0000000..f8adabf
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "frameworkd EFL phonegui"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "e/apps"
+DEPENDS += " dbus-glib libframeworkd-glib libframeworkd-phonegui etk evas ecore edje edje-native elementary"
+PV = "0.0.2+gitr${SRCREV}"
+PR = "r33"
+
+inherit pkgconfig autotools autotools_stage
+
+SRC_URI = "git://git.shr-project.org/repo/shr.git;protocol=http;branch=master"
+S = "${WORKDIR}/git/${PN}"
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+do_configure_prepend() {
+        autopoint --force
+}
+
diff --git a/recipes/shr/libframeworkd-phonegui_git.bb b/recipes/shr/libframeworkd-phonegui_git.bb
new file mode 100644 (file)
index 0000000..50b5465
--- /dev/null
@@ -0,0 +1,15 @@
+DESCRIPTION = "Frameworkd phonegui library"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "libs"
+PV = "0.0.2+gitr${SRCREV}"
+PR = "r10"
+
+DEPENDS="glib-2.0 dbus-glib libframeworkd-glib libphone-utils"
+
+inherit pkgconfig autotools autotools_stage
+
+SRC_URI = "git://git.shr-project.org/repo/shr.git;protocol=http;branch=master"
+S = "${WORKDIR}/git/${PN}"
+
+CONFFILES_${PN} = "${sysconfdir}/frameworkd-phonegui.conf"