python-epydoc: new recipe from SHR
authorMartin Jansa <Martin.Jansa@gmail.com>
Wed, 18 Nov 2009 08:10:13 +0000 (09:10 +0100)
committerMartin Jansa <Martin.Jansa@gmail.com>
Wed, 18 Nov 2009 08:57:27 +0000 (09:57 +0100)
recipes/python/python-epydoc-native_3.0.1.bb [new file with mode: 0644]
recipes/python/python-epydoc_3.0.1.bb [new file with mode: 0644]

diff --git a/recipes/python/python-epydoc-native_3.0.1.bb b/recipes/python/python-epydoc-native_3.0.1.bb
new file mode 100644 (file)
index 0000000..7f64f64
--- /dev/null
@@ -0,0 +1,8 @@
+require python-epydoc_${PV}.bb
+DEPENDS = "python-native"
+inherit native
+
+do_stage() {
+       distutils_stage_all
+}
+
diff --git a/recipes/python/python-epydoc_3.0.1.bb b/recipes/python/python-epydoc_3.0.1.bb
new file mode 100644 (file)
index 0000000..36d22ad
--- /dev/null
@@ -0,0 +1,12 @@
+DESCRIPTION = "Epydoc is a tool for generating API documentation for Python modules, based on their docstrings" 
+SECTION = "devel/python" 
+PRIORITY = "optional" 
+LICENSE = "MIT" 
+HOMEPAGE = "http://epydoc.sourceforge.net/" 
+SRCNAME = "epydoc" 
+DEPENDS = "python" 
+SRC_URI = "http://downloads.sourceforge.net/project/${SRCNAME}/${SRCNAME}/${PV}/${SRCNAME}-${PV}.tar.gz" 
+S = "${WORKDIR}/${SRCNAME}-${PV}" 
+inherit distutils