pidgin: crash and recipe fixes:
authorStanislav Brabec <utx@penguin.cz>
Sat, 10 Oct 2009 10:32:45 +0000 (10:32 +0000)
committerutx@penguin.cz <utx@penguin.cz>
Sat, 10 Oct 2009 10:32:45 +0000 (10:32 +0000)
* Fixed status icon theme crash on startup.
* Use --disable-schemas-install instead of gconf-no-errors.patch.
* Introduced INC_PR.

recipes/pidgin/pidgin.inc
recipes/pidgin/pidgin/gconf-no-errors.patch [deleted file]
recipes/pidgin/pidgin/status-icon-theme-crash.patch [new file with mode: 0644]
recipes/pidgin/pidgin_2.5.8.bb
recipes/pidgin/pidgin_2.6.2.bb

index 7b2f350..14811ae 100644 (file)
@@ -2,6 +2,7 @@ DESCRIPTION = "multi-protocol instant messaging client"
 SECTION = "x11/network"
 LICENSE = "GPL"
 DEPENDS = "python startup-notification avahi gtk+ ncurses gnutls virtual/libintl gstreamer dbus"
+INC_PR = "r1"
 
 inherit autotools gettext pkgconfig gconf
 
@@ -11,6 +12,7 @@ EXTRA_OECONF = " \
                --disable-tcl \
                --disable-deprecated \
                --disable-gevolution \
+               --disable-schemas-install \
                --x-includes=${STAGING_INCDIR} \
                --x-libraries=${STAGING_LIBDIR} \
                --enable-gnutls=yes \
diff --git a/recipes/pidgin/pidgin/gconf-no-errors.patch b/recipes/pidgin/pidgin/gconf-no-errors.patch
deleted file mode 100644 (file)
index 9a95175..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- /tmp/Makefile.am   2007-05-08 18:39:49.000000000 +0200
-+++ pidgin-2.0.0/libpurple/gconf/Makefile.am   2007-05-08 18:40:13.755251000 +0200
-@@ -8,8 +8,7 @@
- if GCONF_SCHEMAS_INSTALL
- install-data-local:
--      GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA) 2>&1 | \
--              grep -v "^WARNING: failed to install schema" | grep -v "^Attached schema" 1>&2
-+      GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA) 2>&1 
- else
- install-data-local:
- endif
diff --git a/recipes/pidgin/pidgin/status-icon-theme-crash.patch b/recipes/pidgin/pidgin/status-icon-theme-crash.patch
new file mode 100644 (file)
index 0000000..0cbd606
--- /dev/null
@@ -0,0 +1,27 @@
+This is a backport of missing chunk of the patch:
+
+Author:        qulogic@pidgin.im
+Changelog:     I guess this pref name was changed but this one line was not. This would
+cause the status icon theme to revert to the default on startup.
+Fixes #10155.
+Date:  Tue, 01 Sep 2009 00:33:52 GMT
+#
+#
+# patch "pidgin/pidginstock.c"
+#  from [2487a2d68312f5afff439a0fa765c3fe40553701]
+#    to [d1da5e342d29fffdf381c68b779c2cb80c5e2caf]
+#
+Index: pidgin-2.6.2/pidgin/pidginstock.c
+===================================================================
+--- pidgin-2.6.2.orig/pidgin/pidginstock.c
++++ pidgin-2.6.2/pidgin/pidginstock.c
+@@ -609,7 +609,8 @@ pidgin_stock_init(void)
+               PidginStatusIconTheme *theme = PIDGIN_STATUS_ICON_THEME(purple_theme_loader_build(PURPLE_THEME_LOADER(loader), path));
+               pidgin_stock_load_status_icon_theme(theme);
+-              g_object_unref(G_OBJECT(theme));
++              if (theme)
++                      g_object_unref(G_OBJECT(theme));
+       }
+       else
index 17d0270..e45c569 100644 (file)
@@ -1,17 +1,17 @@
 require pidgin.inc
+PR = "${INC_PR}.0"
 
 SRC_URI = "\
   ${SOURCEFORGE_MIRROR}/pidgin/pidgin-${PV}.tar.bz2 \
   file://sanitize-configure.ac.patch;patch=1 \
-  file://gconf-no-errors.patch;patch=1 \
   file://pidgin.desktop-set-icon.patch;patch=1 \
   file://purple-OE-branding-25.patch;patch=1 \
   file://pidgin-cross-python.patch;patch=1 \
-" 
+"
 
 EXTRA_OECONF += "\
   --disable-gtkspell \
   --disable-meanwhile \
-  --disable-nm \ 
+  --disable-nm \
   --disable-screensaver \
 "
index e7cb9d6..817e57d 100644 (file)
@@ -1,19 +1,20 @@
 require pidgin.inc
+PR = "${INC_PR}.0"
 
 DEPENDS += "farsight2"
 
 SRC_URI = "\
   ${SOURCEFORGE_MIRROR}/pidgin/pidgin-${PV}.tar.bz2 \
   file://sanitize-configure.ac.patch;patch=1 \
-  file://gconf-no-errors.patch;patch=1 \
   file://pidgin.desktop-set-icon.patch;patch=1 \
   file://purple-OE-branding-25.patch;patch=1 \
   file://pidgin-cross-python.patch;patch=1 \
-" 
+  file://status-icon-theme-crash.patch;patch=1 \
+"
 
 EXTRA_OECONF += "\
   --disable-gtkspell \
   --disable-meanwhile \
-  --disable-nm \ 
+  --disable-nm \
   --disable-screensaver \
 "