lighttpd: add 1.4.13, closes #1662
authorLeon Woestenberg <leon.woestenberg@gmail.com>
Thu, 7 Dec 2006 23:20:12 +0000 (23:20 +0000)
committerKoen Kooi <koen@openembedded.org>
Thu, 7 Dec 2006 23:20:12 +0000 (23:20 +0000)
packages/lighttpd/.mtn2git_empty [new file with mode: 0644]
packages/lighttpd/1.4.13/.mtn2git_empty [new file with mode: 0644]
packages/lighttpd/1.4.13/configure.in.patch [new file with mode: 0644]
packages/lighttpd/1.4.13/src-server.c.patch [new file with mode: 0644]
packages/lighttpd/lighttpd_1.4.13.bb [new file with mode: 0644]

diff --git a/packages/lighttpd/.mtn2git_empty b/packages/lighttpd/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/lighttpd/1.4.13/.mtn2git_empty b/packages/lighttpd/1.4.13/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/lighttpd/1.4.13/configure.in.patch b/packages/lighttpd/1.4.13/configure.in.patch
new file mode 100644 (file)
index 0000000..f4db64d
--- /dev/null
@@ -0,0 +1,28 @@
+Index: lighttpd-1.4.13-r0/lighttpd-1.4.13/configure.in
+===================================================================
+--- lighttpd-1.4.13-r0.orig/lighttpd-1.4.13/configure.in       2006-10-09 18:19:34.000000000 +0200
++++ lighttpd-1.4.13-r0/lighttpd-1.4.13/configure.in    2006-12-07 22:31:52.000000000 +0100
+@@ -250,23 +250,9 @@
+     [WITH_PCRE=$withval],[WITH_PCRE=yes])
+ AC_MSG_RESULT([$WITH_PCRE])
+-if test "x$cross_compiling" = xno -a "$WITH_PCRE" != "no"; then
+-  AC_PATH_PROG(PCRECONFIG, pcre-config)
+-  if test x"$PCRECONFIG" != x; then
+-    PCRE_LIB=`$PCRECONFIG --libs`
+-    CPPFLAGS="$CPPFLAGS `$PCRECONFIG --cflags`"
+-    OLDLIBS="$LIBS"
+-    LIBS="$LIBS $PCRE_LIB"
+-    AC_CHECK_LIB(pcre, pcre_compile, [
+-      AC_CHECK_HEADERS([pcre.h], [
+         AC_DEFINE([HAVE_LIBPCRE], [1], [libpcre])
+         AC_DEFINE([HAVE_PCRE_H], [1])
+-      ])
+-    ])
+-    LIBS="$OLDLIBS"
+-  fi
+-fi
+ AC_SUBST(PCRE_LIB)
diff --git a/packages/lighttpd/1.4.13/src-server.c.patch b/packages/lighttpd/1.4.13/src-server.c.patch
new file mode 100644 (file)
index 0000000..6ca0c9e
--- /dev/null
@@ -0,0 +1,22 @@
+--- lighttpd/src/server.c.orig 2006-03-04 09:12:17.000000000 -0800
++++ lighttpd/src/server.c      2006-07-11 09:16:28.000000000 -0700
+@@ -1174,8 +1174,8 @@
+               if (srv->sockets_disabled) {
+                       /* our server sockets are disabled, why ? */
+-                      if ((srv->cur_fds + srv->want_fds < srv->max_fds * 0.8) && /* we have enough unused fds */
+-                          (srv->conns->used < srv->max_conns * 0.9) &&
++                      if ((srv->cur_fds + srv->want_fds < srv->max_fds * 8 / 10) && /* we have enough unused fds */
++                          (srv->conns->used < srv->max_conns * 9 / 10) &&
+                           (0 == graceful_shutdown)) {
+                               for (i = 0; i < srv->srv_sockets.used; i++) {
+                                       server_socket *srv_socket = srv->srv_sockets.ptr[i];
+@@ -1187,7 +1187,7 @@
+                               srv->sockets_disabled = 0;
+                       }
+               } else {
+-                      if ((srv->cur_fds + srv->want_fds > srv->max_fds * 0.9) || /* out of fds */
++                      if ((srv->cur_fds + srv->want_fds > srv->max_fds * 9 / 10) || /* out of fds */
+                           (srv->conns->used > srv->max_conns) || /* out of connections */
+                           (graceful_shutdown)) { /* graceful_shutdown */ 
diff --git a/packages/lighttpd/lighttpd_1.4.13.bb b/packages/lighttpd/lighttpd_1.4.13.bb
new file mode 100644 (file)
index 0000000..53aa9ff
--- /dev/null
@@ -0,0 +1,28 @@
+DESCRIPTION = "Web server"
+SECTION = "net"
+#DEPENDS = "libpcre openssl"
+LICENSE = "BSD"
+PR = "r0"
+
+SRC_URI = "http://www.lighttpd.net/download/lighttpd-1.4.13.tar.gz \
+file://${PV}/configure.in.patch;patch=1;pnum=2 file://${PV}/src-server.c.patch;patch=1;pnum=1"
+
+EXTRA_OECONF="--without-bzip2 \
+               --without-ldap \
+               --without-lua \
+               --without-memcache \
+               --without-mysql \
+               --without-pcre \
+               --without-openssl \
+               --without-webdav-locks \
+               --without-webdav-props \
+               --disable-nls \
+               --disable-static"
+
+inherit autotools pkgconfig
+
+do_stage() {
+       autotools_stage_all
+}
+
+FILES_${PN} += "${libdir}/mod_*.so"