whois: Add recipe for version 5.0.0.
authorKhem Raj <raj.khem@gmail.com>
Fri, 22 Jan 2010 00:20:25 +0000 (16:20 -0800)
committerKhem Raj <raj.khem@gmail.com>
Fri, 22 Jan 2010 00:20:25 +0000 (16:20 -0800)
* Move to using INC_PR
* Add md5 and sha checksums to recipe.
* Move more common parts like SRC_URI to whois.inc.

* Thanks Paul Menzel for reporting the pending upgrade.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
recipes/whois/whois.inc
recipes/whois/whois_4.5.25.bb
recipes/whois/whois_5.0.0.bb [new file with mode: 0644]

index 15af5e8..f7fc938 100644 (file)
@@ -4,6 +4,14 @@ LICENSE = "GPL"
 HOMEPAGE = "http://www.linux.it/~md/software/"
 SECTION = "network"
 
+INC_PR  = "r1"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/w/whois/whois_${PV}.tar.gz;name=whois"
+
+S = "${WORKDIR}/whois-${PV}"
+
+inherit gettext
+
 def whois_intl(bb, d):
        # FIXME: This is ugly.. we already have the virtual for this,
        # but there's no way to ask bb who the current selected provider of
index 22952b0..2a57467 100644 (file)
@@ -1,6 +1,2 @@
+PR = "${INC_PR}.0"
 require whois.inc
-
-SRC_URI = "${DEBIAN_MIRROR}/main/w/whois/whois_${PV}.tar.gz"
-S = "${WORKDIR}/whois-${PV}"
-
-inherit gettext
diff --git a/recipes/whois/whois_5.0.0.bb b/recipes/whois/whois_5.0.0.bb
new file mode 100644 (file)
index 0000000..a595ec5
--- /dev/null
@@ -0,0 +1,6 @@
+require whois.inc
+PR = "${INC_PR}.0"
+
+SRC_URI[whois.md5sum] = "18d74a07d711262b75f04a1c319bc833"
+SRC_URI[whois.sha256sum] = "fb13316c09ff9f98bd9af659d0789c9a09b97757f5c6c3dbfbc790250d5c5abc"
+