opkg-target,sdk: bump SRCREV
authorKoen Kooi <koen@openembedded.org>
Tue, 24 Nov 2009 09:22:43 +0000 (10:22 +0100)
committerKoen Kooi <koen@openembedded.org>
Tue, 24 Nov 2009 09:22:43 +0000 (10:22 +0100)
* -native is left alone because packaged-staging needs more testing
* tested install and upgrade on angstrom/beagleboard
* tweaked opkg-nogpg-nocurl recipe to keep it building

conf/distro/include/sane-srcrevs.inc
recipes/opkg/opkg-nogpg-nocurl_svn.bb
recipes/opkg/opkg-nogpg_svn.bb
recipes/opkg/opkg.inc

index 7b11e1d..10f943b 100644 (file)
@@ -255,9 +255,9 @@ SRCREV_pn-openmoocow ?= "39648419825cddfea1cb1321e552a12b71fede14"
 SRCREV_pn-openocd ?= "517"
 SRCREV_pn-openocd-native ?= "517"
 SRCREV_pn-opimd-utils ?= "0e7007fff120c8cc4c579c0c7e57883798e6d23e"
-SRCREV_pn-opkg ?= "240"
+SRCREV_pn-opkg ?= "363"
 SRCREV_pn-opkg-native ?= "240"
-SRCREV_pn-opkg-sdk ?= "240"
+SRCREV_pn-opkg-sdk ?= "363"
 SRCREV_pn-opkg-utils ?= "4578"
 SRCREV_pn-opkg-utils-native ?= "4595"
 SRCREV_pn-oprofileui ?= "173"
index 5e1caa9..cd8751a 100644 (file)
@@ -1,24 +1,13 @@
-require opkg_svn.bb
+require opkg-nogpg_svn.bb
 
 DEPENDS = ""
 PROVIDES += "opkg"
 
-SRC_URI += " \
-           file://opkg_wget.patch;patch=1;maxrev=180 \
-           file://reduce-nogpg-noise.patch;patch=1;maxrev=180 \
-           file://opkg_wget_nogpg_01_use_vfork_gunzip.patch;patch=1 \
-           file://opkg_wget_nogpg_02_use_vfork_system.patch;patch=1 \
-           file://opkg_wget_nogpg_03_fix_tmpdirs.patch;patch=1 \
-           file://opkg_wget_nogpg_04_default_tmpdir.patch;patch=1 \
-          "
 PR = "${INC_PR}"
 
 SRCREV = "${SRCREV_pn-opkg}"
 
-EXTRA_OECONF += "--disable-gpg --enable-static --disable-shared"
-
-# NOTE: Use this one after svn rev 180 (should be a different recipe)
-#EXTRA_OECONF += "--disable-gpg --disable-curl --enable-static --disable-shared"
+EXTRA_OECONF += " --disable-curl --enable-static --disable-shared"
 
 # The nogpg version isn't getting much love and has an unused variable which trips up -Werror
 do_configure_prepend() {
index a0f9614..9ddc589 100644 (file)
@@ -3,11 +3,18 @@ require opkg_svn.bb
 DEPENDS = "curl"
 PROVIDES += "opkg"
 
-PR = "${INC_PR}"
+PR = "${INC_PR}.1"
 
 SRCREV = "${SRCREV_pn-opkg}"
 
-EXTRA_OECONF += "--disable-gpg"
+EXTRA_OECONF += " --disable-gpg \ 
+                  --disable-openssl \ 
+                  --disable-ssl-curl \
+                  --enable-gpg=no \
+                  --enable-ssl-curl=no \
+                  --enable-openssl=no"
+
+LDFLAGS_append = " -Wl,--as-needed"
 
 # The nogpg version isn't getting much love and has an unused variable which trips up -Werror
 do_configure_prepend() {
index d744e72..2e7baee 100644 (file)
@@ -10,8 +10,8 @@ FILESPATHPKG =. "opkg:"
 
 SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \
        file://opkg_unarchive.patch;patch=1;maxrev=201 \
-       file://opkg-intercept-cleanup.patch;patch=1 \
-       file://isatty.patch;patch=1"
+       file://opkg-intercept-cleanup.patch;patch=1;maxrev=241 \
+"
 
 SRC_URI += "file://configure"