wv: fix compile problem
authorPetr Štetiar <ynezz@true.cz>
Sun, 8 Nov 2009 17:23:00 +0000 (18:23 +0100)
committerPhil Blundell <philb@gnu.org>
Sun, 8 Nov 2009 17:39:43 +0000 (17:39 +0000)
base_do_compile() checks if there's Makefile or makefile in source directory,
and then it runs oe_runmake. Since there's GNUmakefile generated, change
do_compile accordingly.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
recipes/wv/wv_1.2.0.bb

index 7f06f58..b3114a5 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Programs for accessing Microsoft Word documents"
 HOMEPAGE = "http://wvware.sourceforge.net/"
 LICENSE = "GPLv2"
 DEPENDS = "libgsf glib-2.0"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/wvware/wv-${PV}.tar.gz \
            file://pkgconfig.patch;patch=1"
@@ -16,3 +16,7 @@ EXTRA_OECONF = ""
 do_stage () {
        autotools_stage_all
 }
+
+do_compile () {
+       oe_runmake -f GNUmakefile 
+}