vagalume: add index.theme from shr/merge
authorThomas Zimmermann <zimmermann@vdm-design.de>
Tue, 27 Oct 2009 07:44:09 +0000 (07:44 +0000)
committerMartin Jansa <Martin.Jansa@gmail.com>
Thu, 7 Jan 2010 11:49:57 +0000 (12:49 +0100)
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
recipes/vagalume/files/index.theme [new file with mode: 0644]
recipes/vagalume/vagalume_0.7.1.bb

diff --git a/recipes/vagalume/files/index.theme b/recipes/vagalume/files/index.theme
new file mode 100644 (file)
index 0000000..453acf0
--- /dev/null
@@ -0,0 +1,8 @@
+[Icon Theme]
+Name=Vagalume
+Comment=Vagalume icons
+Directories=scalable/actions
+
+[scalable/actions]
+Size=48
+Type=Scalable
index 5b29ae1..6ef0d19 100644 (file)
@@ -2,13 +2,20 @@ DESCRIPTION = "Last.fm client"
 AUTHOR = "agarcia@igalia.com"
 HOMEPAGE = "http://vagalume.igalia.com/"
 SECTION = "x11"
-DEPENDS = "gtk+ gstreamer"
+DEPENDS = "gtk+ gstreamer curl gst-plugins-good ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'gst-plugins-ugly', d)}"
+RDEPENDS = "curl gst-plugin-autodetect gst-plugin-audioconvert gst-plugin-alsa librsvg-gtk ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'gst-plugin-mad', d)}"
 RRECOMMENDS = "dbus-x11"
+PR = "r2"
 
 SRC_URI = "http://vagalume.igalia.com/files/source/vagalume_${PV}.orig.tar.gz\
+          file://index.theme \
          "
 S = "${WORKDIR}/vagalume-${PV}.orig"
 
 inherit autotools
 
 FILES_${PN} += "${datadir}/icons ${datadir}/dbus-1"
+
+do_install_append() {
+       install -m 0644 ${WORKDIR}/index.theme ${D}${datadir}/vagalume/icons/hicolor
+}