squashfs-tools: refactor 3.3 and 4.0 recipes and use INC_PR
authorOtavio Salvador <otavio@ossystems.com.br>
Sat, 26 Sep 2009 19:25:50 +0000 (16:25 -0300)
committerOtavio Salvador <otavio@ossystems.com.br>
Thu, 8 Oct 2009 00:42:21 +0000 (21:42 -0300)
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
recipes/squashfs-tools/squashfs-tools-native_3.3.bb
recipes/squashfs-tools/squashfs-tools-native_4.0.bb
recipes/squashfs-tools/squashfs-tools.inc
recipes/squashfs-tools/squashfs-tools_3.3.bb
recipes/squashfs-tools/squashfs-tools_4.0.bb

index f27d9ec..d06e1e5 100644 (file)
@@ -1,11 +1,16 @@
 DESCRIPTION = "Squashfs is a highly compressed read-only filesystem for Linux."
 SECTION = "base"
 LICENSE = "GPLv2"
-
 DEPENDS = "zlib"
+INC_PR = "r1"
 
 S = "${WORKDIR}/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}/squashfs-tools"
 
+# required to share same place with -lzma specific packages
+FILESPATHPKG = "squashfs-tools-${PV}:squashfs-tools:files"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}.tar.gz"
+
 prefix = ""
 
 do_compile() {
index 2bf0a98..ce6b7ce 100644 (file)
@@ -1,8 +1,4 @@
 require squashfs-tools.inc
-PR = "r0"
-
-# some release have .tgz, some have .tar.gz, so keep that outside the .inc file
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}.tgz \
-file://Makefile.patch;patch=1"
+PR = "${INC_PR}.1"
 
+SRC_URI += " file://Makefile.patch;patch=1"
index 8299cd6..0de5794 100644 (file)
@@ -1,12 +1,5 @@
 require squashfs-tools.inc
-PR = "r0"
+PR = "${INC_PR}.1"
 
 DEFAULT_PREFERENCE = "-1"
-
-# some release have .tgz, some have .tar.gz, so keep that outside the .inc file
-
-#http://ovh.dl.sourceforge.net/sourceforge/squashfs/squashfs4.0.tar.gz
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}.tar.gz \
-file://Makefile.patch;patch=1"
-
+SRC_URI += " file://Makefile.patch;patch=1"