mpc: New recipe for mpc.
authorKhem Raj <raj.khem@gmail.com>
Mon, 14 Dec 2009 22:56:39 +0000 (14:56 -0800)
committerKhem Raj <raj.khem@gmail.com>
Mon, 14 Dec 2009 23:00:54 +0000 (15:00 -0800)
* mpc will be pre-requisite for gcc 4.5
  currently gcc svn recipes need it.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
conf/checksums.ini
recipes/mpc/mpc-native_0.8.1.bb [new file with mode: 0644]
recipes/mpc/mpc.inc [new file with mode: 0644]
recipes/mpc/mpc_0.8.1.bb [new file with mode: 0644]

index 8bbcd06..e6470d9 100644 (file)
@@ -19158,6 +19158,10 @@ sha256=76e151048a736cf490630ace4909f2d4b65f1afe2447c7fd794d270eb956e045
 md5=48897aeb3a7ee5c64f30e56789f105a8
 sha256=7b549ca4af77fc5b0472df1ecd9e76d2f8415258ddcfb63dfa64a55a04e1e590
 
+[http://www.multiprecision.org/mpc/download/mpc-0.8.1.tar.gz]
+md5=5b34aa804d514cc295414a963aedb6bf
+sha256=e664603757251fd8a352848276497a4c79b7f8b21fd8aedd5cc0598a38fee3e4
+
 [http://downloads.sourceforge.net/musicpd/mpd-0.11.2.tar.gz]
 md5=b6e913dc4b63b161bb1b96030763c3a7
 sha256=e784f78b3cce93367c105619c690465b78a88d3e4c616cc829f4cb5e66f2bbe0
diff --git a/recipes/mpc/mpc-native_0.8.1.bb b/recipes/mpc/mpc-native_0.8.1.bb
new file mode 100644 (file)
index 0000000..8dba0b7
--- /dev/null
@@ -0,0 +1,3 @@
+require mpc_${PV}.bb
+inherit native
+DEPENDS = "mpfr-native gmp-native"
diff --git a/recipes/mpc/mpc.inc b/recipes/mpc/mpc.inc
new file mode 100644 (file)
index 0000000..6e18e58
--- /dev/null
@@ -0,0 +1,6 @@
+DESCRIPTION = "Mpc is a C library for the arithmetic of complex numbers with arbitrarily high precision and correct rounding of the result. It is built upon and follows the same principles as Mpfr"
+HOMEPAGE = "http://www.multiprecision.org/"
+LICENSE = "LGPLv2"
+SECTION = "libs"
+
+inherit autotools
diff --git a/recipes/mpc/mpc_0.8.1.bb b/recipes/mpc/mpc_0.8.1.bb
new file mode 100644 (file)
index 0000000..b62c086
--- /dev/null
@@ -0,0 +1,10 @@
+require mpc.inc
+
+DEPENDS = "gmp mpfr"
+
+SRC_URI = "http://www.multiprecision.org/mpc/download/mpc-${PV}.tar.gz"
+S = "${WORKDIR}/mpc-${PV}"
+
+do_stage() {
+       autotools_stage_all
+}