giac: add 0.8.4
authorKoen Kooi <koen@openembedded.org>
Thu, 14 Jan 2010 10:45:29 +0000 (11:45 +0100)
committerKoen Kooi <koen@openembedded.org>
Thu, 14 Jan 2010 10:48:09 +0000 (11:48 +0100)
conf/checksums.ini
recipes/giac/giac_0.8.4.bb [new file with mode: 0644]

index 18a5dd1..e1b2eaa 100644 (file)
@@ -8762,6 +8762,10 @@ sha256=71e285da2f8f03dd0c6f6a969d1f541ab2a2f1a9d91e26f6f60779897d68824e
 md5=9a34b924ea10ce0a1d62441ee2bacfff
 sha256=80db72ac16463ce084e76dc9aaae5b54ce8db085610c98fe2975c5b8f51a598d
 
+[ftp://ftp-fourier.ujf-grenoble.fr/xcas/giac-0.8.4.tar.gz]
+md5=c0bdb493cfef3dd058cc3750101a4f47
+sha256=354923541221670d48ea2d713abd3fcad94e7f0d220ac9d53e9bcee0eda6ed4a
+
 [http://linuxbrit.co.uk/downloads/giblib-1.2.3.tar.gz]
 md5=06ae3113fdfe9f05a642bd844cc85eab
 sha256=42eb6bff68e88ef12a7ac2aa69848aeb29a8b69176b3bd3d9d67cf9a1233fe85
diff --git a/recipes/giac/giac_0.8.4.bb b/recipes/giac/giac_0.8.4.bb
new file mode 100644 (file)
index 0000000..fa67ace
--- /dev/null
@@ -0,0 +1,39 @@
+DESCRIPTION = "A free computer algebra system"
+HOMEPAGE = "http://www-fourier.ujf-grenoble.fr/~parisse/giac.html"
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "fltk gmp mpfr gsl"
+
+SRC_URI = "ftp://ftp-fourier.ujf-grenoble.fr/xcas/giac-${PV}.tar.gz"
+
+inherit autotools
+
+PARALLEL_MAKE = ""
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_configure() {
+       sed -i -e s:doc::g ${S}/Makefile.am
+       oe_runconf
+       sed -i -e s:doc::g ${S}/Makefile
+}
+
+do_install () {
+        oe_runmake prefix="${D}${prefix}" \
+                bindir="${D}${bindir}" \
+                libdir="${D}${libdir}" \
+                includedir="${D}${includedir}" \
+                install
+}
+
+PACKAGES += " libgiac libxcas"
+
+FILES_${PN} = "${bindir} \
+               ${datadir}/${PN} \
+               ${datadir}/application* \
+               ${datadir}/pixmaps \
+"
+
+FILES_libgiac = "${libdir}/libg*.so.*"
+FILES_libxcas = "${libdir}/libx*.so.*"