iproute2: Use $CC in configure tests.
authorKhem Raj <raj.khem@gmail.com>
Mon, 14 Dec 2009 19:19:24 +0000 (11:19 -0800)
committerKhem Raj <raj.khem@gmail.com>
Mon, 14 Dec 2009 19:19:24 +0000 (11:19 -0800)
* Switch to INC_PR
* honor LDFLAGS env var.
* Use CC env var in configure tests
  currently it uses native gcc which
  is wrong in cross compilation context.
* Fix PR 5147

Signed-off-by: Erik Boto <erik.boto@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
recipes/iproute2/iproute2-2.6.29/use-cross-compiler.patch [new file with mode: 0644]
recipes/iproute2/iproute2.inc
recipes/iproute2/iproute2_2.6.18.bb
recipes/iproute2/iproute2_2.6.20.bb
recipes/iproute2/iproute2_2.6.22.bb
recipes/iproute2/iproute2_2.6.29.bb

diff --git a/recipes/iproute2/iproute2-2.6.29/use-cross-compiler.patch b/recipes/iproute2/iproute2-2.6.29/use-cross-compiler.patch
new file mode 100644 (file)
index 0000000..be5d31d
--- /dev/null
@@ -0,0 +1,53 @@
+Patch to tc/Makefile is from 
+http://bugs.gentoo.org/236861
+
+configure patch is based on suggestion from
+PR 5117
+
+http://bugs.openembedded.org/show_bug.cgi?id=5147
+
+-Khem
+Index: iproute2-2.6.29/configure
+===================================================================
+--- iproute2-2.6.29.orig/configure     2009-12-14 11:07:42.000000000 -0800
++++ iproute2-2.6.29/configure  2009-12-14 11:08:38.000000000 -0800
+@@ -16,7 +16,7 @@ int main(int argc, char **argv) {
+       return 0;
+ }
+ EOF
+-gcc -I$INCLUDE -o /tmp/atmtest /tmp/atmtest.c -latm >/dev/null 2>&1 
++$CC -I$INCLUDE -o /tmp/atmtest /tmp/atmtest.c -latm >/dev/null 2>&1
+ if [ $? -eq 0 ]
+ then
+     echo "TC_CONFIG_ATM:=y" >>Config
+@@ -49,7 +49,7 @@ int main(int argc, char **argv) {
+ }
+ EOF
+-gcc -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl >/dev/null 2>&1
++$CC -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl >/dev/null 2>&1
+ if [ $? -eq 0 ]
+ then
+@@ -81,7 +81,7 @@ int main(int argc, char **argv) {
+ }
+ EOF
+-gcc -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl >/dev/null 2>&1
++$CC -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl >/dev/null 2>&1
+ if [ $? -eq 0 ]
+ then
+Index: iproute2-2.6.29/tc/Makefile
+===================================================================
+--- iproute2-2.6.29.orig/tc/Makefile   2009-12-14 11:10:27.000000000 -0800
++++ iproute2-2.6.29/tc/Makefile        2009-12-14 11:11:39.000000000 -0800
+@@ -100,7 +100,7 @@ clean:
+       rm -f emp_ematch.yacc.output
+ q_atm.so: q_atm.c
+-      $(CC) $(CFLAGS) -shared -fpic -o q_atm.so q_atm.c -latm
++      $(CC) $(CFLAGS) $(LDFLAGS) -shared -fpic -o q_atm.so q_atm.c -latm
+ %.yacc.c: %.y
+       $(YACC) $(YACCFLAGS) -o $@ $<
index 8c8519f..9792bad 100644 (file)
@@ -4,6 +4,8 @@ SECTION = "base"
 LICENSE = "GPL"
 DEPENDS = "flex-native bison-native"
 
+INC_PR = "r3"
+
 # Set the DATE in the .bb file
 SRC_URI = "http://developer.osdl.org/dev/iproute2/download/${P}-${DATE}.tar.gz"
 
index d442a09..32e8711 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "${INC_PR}.0"
 
 require iproute2.inc
 
index e72dfcc..dd1a504 100644 (file)
@@ -1,6 +1,6 @@
 require iproute2.inc
 
-PR = "r2"
+PR = "${INC_PR}.0"
 DATE = "070313"
 
 SRC_URI_append = " file://new-flex-fix.patch;patch=1 \
index 1ee0ce7..55e3a75 100644 (file)
@@ -1,6 +1,6 @@
 require iproute2.inc
 
-PR = "r1"
+PR = "${INC_PR}.0"
 DATE = "070710"
 
 SRC_URI_append = " file://new-flex-fix.patch;patch=1 \
index d02573a..d38dde8 100644 (file)
@@ -1,10 +1,11 @@
 require iproute2.inc
 
-PR = "r1"
+PR = "${INC_PR}.0"
 
 SRC_URI = "http://developer.osdl.org/dev/iproute2/download/${P}.tar.bz2 \
           file://new-flex-fix.patch;patch=1 \
           file://compilation-fix.patch;patch=1 \
+          file://use-cross-compiler.patch;patch=1 \
          "
 
 S = "${WORKDIR}/iproute2-${PV}"