emotion_svn.bb: Make it look for edje_cc in STAGING_DIR.
authorChristopher Friedt <chrisfriedt@gmail.com>
Sat, 8 Aug 2009 07:00:11 +0000 (00:00 -0700)
committerKhem Raj <raj.khem@gmail.com>
Sat, 8 Aug 2009 07:00:11 +0000 (00:00 -0700)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
recipes/efl1/emotion_svn.bb

index 0f31e66..79b35d9 100644 (file)
@@ -3,7 +3,7 @@ LICENSE = "MIT BSD"
 # we no longer build the libxine backend, since the gstreamer backend seems more promising
 DEPENDS = "eet evas ecore edje gstreamer gst-plugins-base"
 PV = "0.1.0.042+svnr${SRCREV}"
-PR = "r2"
+PR = "r3"
 
 inherit efl
 
@@ -12,3 +12,11 @@ EXTRA_OECONF = "--disable-xine --enable-gstreamer --with-edje-cc=${STAGING_BINDI
 PACKAGES =+ "emotion-backend-gstreamer"
 FILES_emotion-backend-gstreamer = "${libdir}/emotion/*.so"
 RRECOMMENDS_${PN} = "emotion-backend-gstreamer"
+
+
+do_configure_append() {
+       for i in $(find ${WORKDIR}/emotion -name 'Makefile'); do 
+               sed -i -e s:/usr/bin/edje_cc:${STAGING_DIR}/${BUILD_SYS}/usr/bin/edje_cc: \
+                       ${i}
+       done
+}