watchdog: Update to version 5.6
authorMark Brown <broonie@opensource.wolfsonmicro.com>
Thu, 2 Apr 2009 10:38:14 +0000 (11:38 +0100)
committerMark Brown <broonie@opensource.wolfsonmicro.com>
Wed, 8 Apr 2009 12:50:24 +0000 (13:50 +0100)
No packaging changes, just the new upstream.

Acked-by: Koen Kooi <koen@openembedded.org>
conf/checksums.ini
recipes/watchdog/watchdog_5.6.bb [new file with mode: 0644]

index ce78b83..d08d7bc 100644 (file)
@@ -23466,6 +23466,11 @@ sha256=6c5bfb2edae5c289233b6cd65393bb7414a2d30ad4d1239c207a659a4232d91a
 md5=ba97ddce396bfccd8d409bc3141d7ef4
 sha256=b7bf9feeedea26d7e06935369a1a556089426e94f9ead946018526c96cd9b12e
 
+[http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/watchdog-5.6.tar.gz]
+md5=6df285569dd1d85528b983c98c9b2b7c
+sha256=a2c7d6726e092315dbb047211b754528e4532521678a30e16f60a31bb86a7f74
+
+
 [http://downloads.sourceforge.net/wbxmllib/wbxml2-0.9.0-src.tar.gz]
 md5=3f9b5bf104ec523b8eebe69f93919ded
 sha256=acd218148d7f92ee7bd0539d6aabd0b42cca8ae4ffe241bfa8760d30605b28c9
diff --git a/recipes/watchdog/watchdog_5.6.bb b/recipes/watchdog/watchdog_5.6.bb
new file mode 100644 (file)
index 0000000..6c8bd56
--- /dev/null
@@ -0,0 +1,16 @@
+DESCRIPTION = "System watchdog daemon"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/${PN}-${PV}.tar.gz \
+       file://init"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "watchdog"
+INITSCRIPT_PARAMS = "defaults 10"
+
+do_install_append() {
+       install -d ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/watchdog
+}
+