open-iscsi: added recipe; still needs stress-testing
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>
Mon, 26 Oct 2009 15:42:07 +0000 (16:42 +0100)
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>
Mon, 26 Oct 2009 15:42:07 +0000 (16:42 +0100)
conf/checksums.ini
recipes/open-iscsi/open-iscsi-kernel_2.0-871.bb [new file with mode: 0644]
recipes/open-iscsi/open-iscsi-user_2.0-871.bb [new file with mode: 0644]

index 85ef9dd..290e5f6 100644 (file)
@@ -19310,6 +19310,10 @@ sha256=b1fb3bad0c8581b82f0da9c69673f43ad9aed7868a7e4f2a68c6c72ed656237b
 md5=43b363c860780e7f1a0361cfee8f9f4a
 sha256=60c9d75703bedfeca7140cb76b23fae7179ce1f86e7e8b0026b72d66acd75c82
 
+[http://www.open-iscsi.org/bits/open-iscsi-2.0-871.tar.gz]
+md5=0c403e8c9ad41607571ba0e6e8ff196e
+sha256=bcea8746ae82f2ada7bc05d2aa59bcda1ca0d5197f05f2e16744aae59f0a7dcb
+
 [http://www.openal.org/openal_webstf/downloads/openal-0.0.8.tar.gz]
 md5=641cf53761f35ee979f3e888614797a0
 sha256=723e2c57c3cdffa7ff11f9b6b5478d6cb4af017e5a1ee7a56032969c39c1c2fe
diff --git a/recipes/open-iscsi/open-iscsi-kernel_2.0-871.bb b/recipes/open-iscsi/open-iscsi-kernel_2.0-871.bb
new file mode 100644 (file)
index 0000000..c58e142
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "Open-iSCSI project is a high performance, transport independent, multi-platform implementation of RFC3720."
+HOMEPAGE = "http://www.open-iscsi.org/"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.open-iscsi.org/bits/open-iscsi-${PV}.tar.gz"
+S = "${WORKDIR}/open-iscsi-${PV}"
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+inherit module
+
+do_compile () {
+        oe_runmake 'KSRC=${STAGING_KERNEL_DIR}' LDFLAGS="" kernel
+}
+
+do_install() {
+        oe_runmake 'KSRC=${STAGING_KERNEL_DIR}' LDFLAGS="" DESTDIR="${D}" install_kernel
+}
+
diff --git a/recipes/open-iscsi/open-iscsi-user_2.0-871.bb b/recipes/open-iscsi/open-iscsi-user_2.0-871.bb
new file mode 100644 (file)
index 0000000..92ecea1
--- /dev/null
@@ -0,0 +1,16 @@
+DESCRIPTION = "Open-iSCSI project is a high performance, transport independent, multi-platform implementation of RFC3720."
+HOMEPAGE = "http://www.open-iscsi.org/"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.open-iscsi.org/bits/open-iscsi-${PV}.tar.gz"
+S = "${WORKDIR}/open-iscsi-${PV}"
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_compile () {
+        oe_runmake user
+}
+
+do_install () {
+        oe_runmake DESTDIR="${D}" install_user
+}