glib-2.0_2.22.4.bb : add new version totally clean recipe
authorGraeme Gregory <dp@xora.org.uk>
Mon, 25 Jan 2010 21:02:57 +0000 (21:02 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Mon, 25 Jan 2010 21:02:57 +0000 (21:02 +0000)
The glib-2.0 recipe seemed to have gained a lot of un-needed extras and
was also out of date for BBCLASSEXTEND and staging. So this is a minimalised
new version.

recipes/glib-2.0/glib-2.0-2.22.4/atomic-thumb.patch [new file with mode: 0644]
recipes/glib-2.0/glib-2.0-2.22.4/configure-libtool.patch [new file with mode: 0644]
recipes/glib-2.0/glib-2.0-2.22.4/g_once_init_enter.patch [new file with mode: 0644]
recipes/glib-2.0/glib-2.0-2.22.4/gobject.patch [new file with mode: 0644]
recipes/glib-2.0/glib-2.0-2.22.4/uclibc-res_query.patch [new file with mode: 0644]
recipes/glib-2.0/glib-2.0_2.22.4.bb [new file with mode: 0644]

diff --git a/recipes/glib-2.0/glib-2.0-2.22.4/atomic-thumb.patch b/recipes/glib-2.0/glib-2.0-2.22.4/atomic-thumb.patch
new file mode 100644 (file)
index 0000000..d7aa088
--- /dev/null
@@ -0,0 +1,42 @@
+# gatomic.c uses SWP, which doesn't work in Thumb mode.
+# Put that source file into a separate convenience library which is always built as ARM.
+
+Index: glib-2.18.1/glib/Makefile.am
+===================================================================
+--- glib-2.18.1/glib/Makefile.am       2008-09-18 00:33:57.000000000 +0200
++++ glib-2.18.1/glib/Makefile.am       2008-11-08 10:13:27.000000000 +0100
+@@ -80,6 +80,7 @@
+       galiasdef.c
+ lib_LTLIBRARIES = libglib-2.0.la
++noinst_LTLIBRARIES = libgatomic.la
+ if OS_WIN32_AND_DLL_COMPILATION
+ if MS_LIB_AVAILABLE
+@@ -96,10 +97,14 @@
+ uninstall-ms-lib:
+       $(uninstall_ms_lib_cmd)
++libgatomic_la_CFLAGS = $(CFLAGS) -mno-thumb
++
++libgatomic_la_SOURCES =                \
++       gatomic.c
++ 
+ libglib_2_0_la_SOURCES =      \
+       garray.c                \
+       gasyncqueue.c           \
+-      gatomic.c               \
+       gbacktrace.c            \
+       gbase64.c               \
+       gbookmarkfile.c         \
+@@ -286,8 +291,8 @@
+ pcre_inc =
+ endif
+-libglib_2_0_la_LIBADD = libcharset/libcharset.la $(printf_la) @GIO@ @GSPAWN@ @PLATFORMDEP@ @ICONV_LIBS@ @G_LIBS_EXTRA@ $(pcre_lib)
+-libglib_2_0_la_DEPENDENCIES = libcharset/libcharset.la $(printf_la) @GIO@ @GSPAWN@ @PLATFORMDEP@ $(glib_win32_res) $(glib_def)
++libglib_2_0_la_LIBADD = libcharset/libcharset.la $(printf_la) @GIO@ @GSPAWN@ @PLATFORMDEP@ @ICONV_LIBS@ @G_LIBS_EXTRA@ $(pcre_lib) libgatomic.la
++libglib_2_0_la_DEPENDENCIES = libcharset/libcharset.la $(printf_la) @GIO@ @GSPAWN@ @PLATFORMDEP@ $(glib_win32_res) $(glib_def) libgatomic.la
+ libglib_2_0_la_LDFLAGS = \
+        $(glib_win32_res_ldflag) \
diff --git a/recipes/glib-2.0/glib-2.0-2.22.4/configure-libtool.patch b/recipes/glib-2.0/glib-2.0-2.22.4/configure-libtool.patch
new file mode 100644 (file)
index 0000000..3ba79b8
--- /dev/null
@@ -0,0 +1,34 @@
+# Poky renames libtool to $host_alias-libtool.
+# ./$host_alias-libtool isn't created until after configure runs with libtool >= 2.2.2
+# so we can't call # it at this point. We can safely assume a version is available 
+# from PATH though
+
+--- glib-2.12.10/configure.in.orig     2006-06-05 13:34:08.000000000 +0100
++++ glib-2.12.10/configure.in  2006-06-05 13:34:36.000000000 +0100
+@@ -1174,7 +1174,7 @@
+   G_MODULE_LDFLAGS=
+ else
+   export SED
+-  G_MODULE_LDFLAGS=`(./libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
++  G_MODULE_LDFLAGS=`($host_alias-libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
+ fi
+ dnl G_MODULE_IMPL= don't reset, so cmd-line can override
+ G_MODULE_NEED_USCORE=0
+@@ -1265,7 +1265,7 @@
+       LDFLAGS="$LDFLAGS $G_MODULE_LDFLAGS"
+ dnl *** check for OSF1/5.0 RTLD_GLOBAL brokenness
+       echo "void glib_plugin_test(void) { }" > plugin.c
+-      ${SHELL} ./libtool --mode=compile ${CC} -shared \
++      ${SHELL} $host_alias-libtool --mode=compile ${CC} -shared \
+               -export-dynamic -o plugin.o plugin.c 2>&1 >/dev/null
+       AC_CACHE_CHECK([for RTLD_GLOBAL brokenness],
+               glib_cv_rtldglobal_broken,[
+@@ -1339,7 +1339,7 @@
+ AC_MSG_CHECKING(for the suffix of shared libraries)
+ export SED
+-shrext_cmds=`./libtool --config | grep '^shrext_cmds='`
++shrext_cmds=`$host_alias-libtool --config | grep '^shrext_cmds='`
+ eval $shrext_cmds
+ module=yes eval std_shrext=$shrext_cmds
+ # chop the initial dot
diff --git a/recipes/glib-2.0/glib-2.0-2.22.4/g_once_init_enter.patch b/recipes/glib-2.0/glib-2.0-2.22.4/g_once_init_enter.patch
new file mode 100644 (file)
index 0000000..58e4108
--- /dev/null
@@ -0,0 +1,11 @@
+--- glib-2.22.1/glib/gthread.h.orig    2009-10-13 22:53:23.000000000 +0200
++++ glib-2.22.1/glib/gthread.h 2009-10-13 23:34:59.000000000 +0200
+@@ -341,7 +341,7 @@
+ G_INLINE_FUNC gboolean
+ g_once_init_enter (volatile gsize *value_location)
+ {
+-  if G_LIKELY ((gpointer) g_atomic_pointer_get (value_location) != NULL)
++  if G_LIKELY ((gpointer) g_atomic_pointer_get ((volatile gpointer *)value_location) != NULL)
+     return FALSE;
+   else
+     return g_once_init_enter_impl (value_location);
diff --git a/recipes/glib-2.0/glib-2.0-2.22.4/gobject.patch b/recipes/glib-2.0/glib-2.0-2.22.4/gobject.patch
new file mode 100644 (file)
index 0000000..d9c7b7e
--- /dev/null
@@ -0,0 +1,99 @@
+diff --git a/gobject/gobject.c b/gobject/gobject.c
+index 454d8c2..60c502b 100644
+--- a/gobject/gobject.c
++++ b/gobject/gobject.c
+@@ -182,7 +182,7 @@ static GQuark                  quark_closure_array = 0;
+ static GQuark             quark_weak_refs = 0;
+ static GQuark             quark_toggle_refs = 0;
+ static GParamSpecPool      *pspec_pool = NULL;
+-static GObjectNotifyContext property_notify_context = { 0, };
++static GObjectNotifyContext property_notify_context = { G_STATIC_PRIVATE_INIT, };
+ static gulong             gobject_signals[LAST_SIGNAL] = { 0, };
+ static guint (*floating_flag_handler) (GObject*, gint) = object_floating_flag_handler;
+ G_LOCK_DEFINE_STATIC (construction_mutex);
+@@ -321,7 +321,6 @@ g_object_do_class_init (GObjectClass *class)
+   quark_weak_refs = g_quark_from_static_string ("GObject-weak-references");
+   quark_toggle_refs = g_quark_from_static_string ("GObject-toggle-references");
+   pspec_pool = g_param_spec_pool_new (TRUE);
+-  property_notify_context.quark_notify_queue = g_quark_from_static_string ("GObject-notify-queue");
+   property_notify_context.dispatcher = g_object_notify_dispatcher;
+   
+   class->constructor = g_object_constructor;
+diff --git a/gobject/gobjectnotifyqueue.c b/gobject/gobjectnotifyqueue.c
+index 1d5787b..173a8ed 100644
+--- a/gobject/gobjectnotifyqueue.c
++++ b/gobject/gobjectnotifyqueue.c
+@@ -38,7 +38,7 @@ typedef void (*GObjectNotifyQueueDispatcher) (GObject     *object,
+ /* --- structures --- */
+ struct _GObjectNotifyContext
+ {
+-  GQuark                       quark_notify_queue;
++  GStaticPrivate               key_notify_objects;
+   GObjectNotifyQueueDispatcher dispatcher;
+   GTrashStack                 *_nqueue_trash; /* unused */
+ };
+@@ -68,16 +68,27 @@ static inline GObjectNotifyQueue*
+ g_object_notify_queue_freeze (GObject            *object,
+                             GObjectNotifyContext *context)
+ {
++  GHashTable *objects;
+   GObjectNotifyQueue *nqueue;
+-  nqueue = g_datalist_id_get_data (&object->qdata, context->quark_notify_queue);
++  objects = g_static_private_get (&context->key_notify_objects);
++  if (!objects)
++    {
++      objects = g_hash_table_new_full (g_direct_hash, g_direct_equal,
++        NULL, g_object_notify_queue_free);
++
++      g_static_private_set (&context->key_notify_objects, objects,
++        (GDestroyNotify) g_hash_table_unref);
++    }
++
++  nqueue = g_hash_table_lookup (objects, object);
+   if (!nqueue)
+     {
+       nqueue = (void*) g_list_alloc ();
+       memset (nqueue, 0, sizeof (*nqueue));
+       nqueue->context = context;
+-      g_datalist_id_set_data_full (&object->qdata, context->quark_notify_queue,
+-                                 nqueue, g_object_notify_queue_free);
++
++      g_hash_table_insert (objects, object, nqueue);
+     }
+   g_return_val_if_fail (nqueue->freeze_count < 65535, nqueue);
+@@ -94,6 +105,7 @@ g_object_notify_queue_thaw (GObject            *object,
+   GParamSpec *pspecs_mem[16], **pspecs, **free_me = NULL;
+   GSList *slist;
+   guint n_pspecs = 0;
++  GHashTable *objects;
+   g_return_if_fail (nqueue->freeze_count > 0);
+@@ -119,7 +131,10 @@ g_object_notify_queue_thaw (GObject            *object,
+       pspecs[n_pspecs++] = pspec;
+     }
+-  g_datalist_id_set_data (&object->qdata, context->quark_notify_queue, NULL);
++  objects = g_static_private_get (&context->key_notify_objects);
++  g_hash_table_remove (objects, object);
++  if (g_hash_table_size (objects) == 0)
++    g_static_private_set (&context->key_notify_objects, NULL, NULL);
+   if (n_pspecs)
+     context->dispatcher (object, n_pspecs, pspecs);
+@@ -162,7 +177,13 @@ static inline GObjectNotifyQueue*
+ g_object_notify_queue_from_object (GObject              *object,
+                                  GObjectNotifyContext *context)
+ {
+-  return g_datalist_id_get_data (&object->qdata, context->quark_notify_queue);
++  GHashTable *objects;
++
++  objects = g_static_private_get (&context->key_notify_objects);
++  if (objects == NULL)
++    return NULL;
++
++  return g_hash_table_lookup (objects, object);
+ }
diff --git a/recipes/glib-2.0/glib-2.0-2.22.4/uclibc-res_query.patch b/recipes/glib-2.0/glib-2.0-2.22.4/uclibc-res_query.patch
new file mode 100644 (file)
index 0000000..bbb34b5
--- /dev/null
@@ -0,0 +1,36 @@
+Index: glib-2.22.1/configure.in
+===================================================================
+--- glib-2.22.1.orig/configure.in      2009-12-08 12:01:39.000000000 -0800
++++ glib-2.22.1/configure.in   2009-12-08 12:05:29.000000000 -0800
+@@ -1004,17 +1004,22 @@ if test $glib_native_win32 = no; then
+   AC_CHECK_FUNC(res_query, ,
+     [AC_CHECK_LIB(resolv, res_query, [ LIBASYNCNS_LIBADD="-lresolv" ],
+       [ save_libs="$LIBS"
+-        LIBS="-lresolv $LIBS"
+-        AC_MSG_CHECKING([for res_query in -lresolv (alternate version)])
++        AC_MSG_CHECKING([for res_query (alternate version)])
+         AC_LINK_IFELSE(
+           [AC_LANG_PROGRAM([[#include <resolv.h>]], [[res_query(0,0,0,0,0)]])],
+-          [ AC_MSG_RESULT(yes)
+-        LIBASYNCNS_LIBADD="-lresolv" ],
+-          [ AC_MSG_RESULT(no)
+-            AC_CHECK_LIB(bind, res_query,
+-              [ LIBASYNCNS_LIBADD="-lbind" ],
+-          [ AC_MSG_ERROR(res_query not found) ] ) ] )
+-        LIBS="$save_libs"
++          [ ac_cv_func_res_query=yes ],
++          [ AC_MSG_CHECKING([for res_query in -lresolv (alternate version)])
++          LIBS="-lresolv $LIBS"
++          AC_LINK_IFELSE(
++            [AC_LANG_PROGRAM([[#include <resolv.h>]], [[res_query(0,0,0,0,0)]])],
++            [ AC_MSG_RESULT(yes)
++              LIBASYNCNS_LIBADD="-lresolv" ],
++            [ AC_MSG_RESULT(no)
++                AC_CHECK_LIB(bind, res_query,
++                [ LIBASYNCNS_LIBADD="-lbind" ],
++              [ AC_MSG_ERROR(res_query not found) ] ) ] )
++        ] )
++          LIBS="$save_libs"
+       ] )
+     ]
+   )
diff --git a/recipes/glib-2.0/glib-2.0_2.22.4.bb b/recipes/glib-2.0/glib-2.0_2.22.4.bb
new file mode 100644 (file)
index 0000000..eff5fbd
--- /dev/null
@@ -0,0 +1,74 @@
+DESCRIPTION = "GLib is a general-purpose utility library, \
+which provides many useful data types, macros, \
+type conversions, string utilities, file utilities, a main \
+loop abstraction, and so on. It works on many \
+UNIX-like platforms, Windows, OS/2 and BeOS."
+LICENSE = "LGPL"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "glib-2.0-native gtk-doc virtual/libiconv virtual/libintl"
+
+SRC_URI = "\
+  http://ftp.gnome.org/pub/GNOME/sources/glib/2.22/glib-${PV}.tar.bz2;name=archive \
+  file://glibconfig-sysdefs.h \
+  file://configure-libtool.patch;patch=1 \
+  file://g_once_init_enter.patch;patch=1 \
+  file://uclibc-res_query.patch;patch=1 \
+"
+SRC_URI[archive.md5sum] = "d91bcbe27556430ddecce65086355708"
+SRC_URI[archive.sha256sum] = "0d1f6bf8aaeab772f2370229eefda45bef434e3f29a7d1d8e5dfafeaa1d8ad14"
+
+SRC_URI_append_arm = " file://atomic-thumb.patch;patch=1"
+SRC_URI_append_armv6 = " file://gatomic_armv6.patch;patch=1"
+SRC_URI_append_armv7a = " file://gatomic_armv6.patch;patch=1" 
+
+PR = "r0"
+
+inherit autotools gettext
+
+S = "${WORKDIR}/glib-${PV}"
+
+EXTRA_OECONF = "--disable-debug "
+
+# Add and entry for your favourite arch if your (g)libc has a sane printf
+EXTRA_OECONF_append_glibc_arm = "  --enable-included-printf=no "
+
+do_configure_prepend () {
+       install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h .
+}
+
+do_install_append() {
+       sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g ${D}${bindir}/glib-mkenums || true
+}
+
+DEPENDS_virtclass-native = "gettext-native gtk-doc-native"
+EXTRA_OECONF_virtclass-native = ""
+
+do_configure_prepend_virtclass-native() {
+    if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
+                echo "${TARGET_SYS}-libtool already present"
+    else
+        cp ${STAGING_BINDIR}/${TARGET_SYS}-libtool ${S}
+    fi
+
+}
+
+BBCLASSEXTEND = "native"
+
+PACKAGES =+ "gobject-2.0 gmodule-2.0 gthread-2.0 gio-2.0 glib-2.0-utils "
+LEAD_SONAME = "libglib-2.0.*"
+FILES_glib-2.0-utils = "${bindir}/*"
+FILES_${PN} = "${libdir}/lib*so.* ${libdir}/gio/modules/*.so"
+FILES_${PN}-dev += "${libdir}/glib-2.0 ${datadir}/glib-2.0 ${libdir}/gio/modules/*.la"
+FILES_${PN}-dbg += "${libdir}/gio/modules/.debug"
+FILES_gmodule-2.0 = "${libdir}/libgmodule-2.0.so.*"
+FILES_gobject-2.0 = "${libdir}/libgobject-2.0.so.*"
+FILES_gio-2.0 = "${libdir}/libgio-2.0.so.*"
+FILES_gthread-2.0 = "${libdir}/libgthread-2.0.so.*"
+
+# Let various glib components end up in glib package
+# for compatibility (with binary packages from Maemo).
+FILES_gthread-2.0_chinook-compat = ""
+FILES_gmodule-2.0_chinook-compat = ""
+FILES_gobject-2.0_chinook-compat = ""
+FILES_gio-2.0_chinook-compat = ""