omap3-sgx-modules: fix build under 2.6.27
authorGrazvydas Ignotas <notasas@gmail.com>
Sat, 22 Jan 2011 22:10:41 +0000 (00:10 +0200)
committerGrazvydas Ignotas <notasas@gmail.com>
Sat, 22 Jan 2011 22:14:31 +0000 (00:14 +0200)
remove a patch for newer kernels that breaks .27,
add patch prefix to patches (needed for old OE) and
set platform to 3430 (3630 code looks unsafe for 3430 for me).

recipes/powervr-drivers/omap3-sgx-modules/fix-2.6.27.patch [new file with mode: 0644]
recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb

diff --git a/recipes/powervr-drivers/omap3-sgx-modules/fix-2.6.27.patch b/recipes/powervr-drivers/omap3-sgx-modules/fix-2.6.27.patch
new file mode 100644 (file)
index 0000000..5a9ca4f
--- /dev/null
@@ -0,0 +1,27 @@
+diff -ur GFX_Linux_KM/services4/3rdparty/dc_omap3430_linux/omaplfb_linux.c /tmp/gs/GFX_Linux_KM/services4/3rdparty/dc_omap3430_linux/omaplfb_linux.c
+--- GFX_Linux_KM/services4/3rdparty/dc_omap3430_linux/omaplfb_linux.c  2010-09-08 09:06:41.000000000 +0300
++++ GFX_Linux_KM/services4/3rdparty/dc_omap3430_linux/omaplfb_linux.c  2011-01-22 19:29:58.814352221 +0200
+@@ -56,7 +56,11 @@
+ extern void omap_dispc_free_irq(unsigned long, void (*)(void *), void *);
+ extern void omap_dispc_set_plane_base(int plane, IMG_UINT32 phys_addr);
+ #else
++#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,32))
+ #include <plat/display.h>
++#else
++#include <mach/display.h>
++#endif
+ #include <linux/console.h>
+ #include <linux/fb.h>
+ static omap_dispc_isr_t *pOMAPLFBVSyncISRHandle = NULL;
+diff -ur GFX_Linux_KM/services4/system/omap3430/sysutils_linux.c /tmp/gs/GFX_Linux_KM/services4/system/omap3430/sysutils_linux.c
+--- GFX_Linux_KM/services4/system/omap3430/sysutils_linux.c    2010-03-05 11:47:57.000000000 +0200
++++ GFX_Linux_KM/services4/system/omap3430/sysutils_linux.c    2011-01-22 19:28:23.287592886 +0200
+@@ -39,8 +39,6 @@
+ #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,26))
+ #include <linux/semaphore.h>
+-#include <mach/resource.h>
+-#include <mach/omap-pm.h>
+ #else
+ #include <asm/semaphore.h>
+ #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,22))
index d35da45..348d8c9 100644 (file)
@@ -17,9 +17,9 @@ inherit module
 MACHINE_KERNEL_PR_append = "h"
 
 SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/Graphics_SDK_setuplinux_${SGXPV}.bin \
-           file://0002-Compile-fixes-for-recent-kernels.patch \
-           file://update.patch \
-           file://0001-OMAP3-SGX-TI-4.00.00.01-2.6.37-rc1-use-semaphore-ove.patch \
+           file://0002-Compile-fixes-for-recent-kernels.patch;patch=1 \
+           file://0001-OMAP3-SGX-TI-4.00.00.01-2.6.37-rc1-use-semaphore-ove.patch;patch=1 \
+           file://fix-2.6.27.patch;patch=1 \
 "
 
 SRC_URI[md5sum] = "a027002dcd7164df467b1a315788d5fd"
@@ -31,7 +31,8 @@ PVRBUILD = "release"
 
 PACKAGE_STRIP = "no"
 
-TI_PLATFORM_omap3 = "omap3630"
+TI_PLATFORM_omap3-pandora = "omap3430"
+#TI_PLATFORM_omap3 = "omap3630"
 TI_PLATFORM_ti816x = "ti8168"
 
 MODULESLOCATION_omap3 = "dc_omap3430_linux"