mc: fix configure
authorHenning Heinold <heinold@inf.fu-berlin.de>
Thu, 24 Sep 2009 11:05:24 +0000 (13:05 +0200)
committerHenning Heinold <heinold@inf.fu-berlin.de>
Thu, 24 Sep 2009 11:07:08 +0000 (13:07 +0200)
* delete all auto-config files in config
* inherit gettext in .inc
* bump PR

recipes/mc/mc.inc
recipes/mc/mc_4.6.2.bb

index 9d00aca..f7db53f 100644 (file)
@@ -9,7 +9,7 @@ RDEPENDS = "ncurses-terminfo"
 
 SRC_URI = "http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/mc-${PV}.tar.gz"
 
-inherit autotools
+inherit autotools gettext
 
 EXTRA_OECONF = "--disable-glibtest --without-x --without-samba \
 --without-nfs --without-gpm-mouse --with-screen=ncurses \
index 10da272..387187d 100644 (file)
@@ -1,5 +1,5 @@
 require mc.inc
-PR = "r3"
+PR = "r4"
 HOMEPAGE = "http://www.midnight-commander.org/"
 
 # most of these fixes were copied from openSUSE Factory.
@@ -78,3 +78,12 @@ do_utf8_conversion() {
        popd
        popd
 }
+
+do_configure_prepend() {
+
+AUTOFOO="config.guess config.rpath config.sub depcomp install-sh missing mkinstalldirs"
+
+         for i in ${AUTOFOO}; do
+           rm config/${i}
+         done
+}