libgsm: fix install, don't use hardcoded include path
authorHenning Heinold <heinold@inf.fu-berlin.de>
Sat, 1 Aug 2009 20:43:16 +0000 (22:43 +0200)
committerHenning Heinold <heinold@inf.fu-berlin.de>
Sat, 15 Aug 2009 16:29:51 +0000 (18:29 +0200)
* bump PR

recipes/libgsm/libgsm_1.0.12.bb

index 9c96f4d..d24cbdb 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "optional"
 #DEPENDS = ""
 LICENSE = "libgsm"
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "http://user.cs.tu-berlin.de/~jutta/gsm/gsm-${PV}.tar.gz \
           file://01_makefile.patch;patch=1 \
@@ -28,9 +28,9 @@ do_compile() {
 do_install() {
        oe_libinstall -a -C lib libgsm ${D}${libdir}
         oe_libinstall -so -C lib libgsm ${D}${libdir}
-        install -d ${D}/usr/include/gsm
-        install -m 0644 ${S}/inc/gsm.h ${D}/usr/include/gsm/
-       cd ${D}/usr/include/
+        install -d ${D}${includedir}/gsm
+        install -m 0644 ${S}/inc/gsm.h ${D}${includedir}/gsm/
+       cd ${D}${includedir}
        ln -s gsm/gsm.h gsm.h
 }