mp3blaster: added version 3.2.5
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Fri, 12 Mar 2010 20:41:29 +0000 (21:41 +0100)
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Sun, 28 Mar 2010 16:14:44 +0000 (18:14 +0200)
According to their website(for version 3.2.4) "This version fixes
  skips and hickups when using SDL audio output.
  Also, when changing back directories in the file browser,
  it will jump back to the subdirectory the user came from."
With my setup(eee701),it didn't solved the problem completely,
  but still,the audio was better.

And(for version 3.2.5) :
  "This version only contains some minor compliation fixes"

The path was rebased.
Maybe it should be submited upstream.

recipes/mp3blaster/mp3blaster-3.2.5/includedir.patch [new file with mode: 0644]
recipes/mp3blaster/mp3blaster_3.2.5.bb [new file with mode: 0644]

diff --git a/recipes/mp3blaster/mp3blaster-3.2.5/includedir.patch b/recipes/mp3blaster/mp3blaster-3.2.5/includedir.patch
new file mode 100644 (file)
index 0000000..5568898
--- /dev/null
@@ -0,0 +1,37 @@
+Index: mp3blaster-3.2.5/mpegsound/Makefile.am
+===================================================================
+--- mp3blaster-3.2.5.orig/mpegsound/Makefile.am
++++ mp3blaster-3.2.5/mpegsound/Makefile.am
+@@ -12,5 +12,5 @@ libmpegsound_a_SOURCES  = soundinputstre
+ noinst_HEADERS                = mpegsound.h mpegsound_locals.h
+-INCLUDES                = -I$(srcdir) -I$(includedir)
++INCLUDES                = -I$(srcdir)
+ AM_CXXFLAGS             = @NAS_CFLAGS@
+Index: mp3blaster-3.2.5/nmixer/Makefile.am
+===================================================================
+--- mp3blaster-3.2.5.orig/nmixer/Makefile.am
++++ mp3blaster-3.2.5/nmixer/Makefile.am
+@@ -2,7 +2,7 @@ bin_PROGRAMS   = nmixer
+ nmixer_SOURCES        = main.cc
+ nmixer_DEPENDENCIES = libnmixer.a
+ LDADD           = @NCURSES_LIBS@ @NAS_LIBS@ @LIBNMIXER@
+-INCLUDES              = -I/usr/include/ncurses -I$(srcdir) -I$(includedir)
++INCLUDES              = -I$(srcdir)
+ noinst_LIBRARIES = libnmixer.a
+ libnmixer_a_SOURCES = nmixer.cc mixers.cc ossmixer.cc nasmixer.cc nmixer.h \
+                       getopt.c getopt1.c getopt_local.h nullmixer.cc
+Index: mp3blaster-3.2.5/src/Makefile.am
+===================================================================
+--- mp3blaster-3.2.5.orig/src/Makefile.am
++++ mp3blaster-3.2.5/src/Makefile.am
+@@ -35,7 +35,7 @@ mp3tag_SOURCES = id3parse.cc mp3tag.cc i
+ mp3tag_DEPENDENCIES = ../mpegsound/libmpegsound.a ../nmixer/libnmixer.a
+ mp3tag_LDADD = @LIBMPEGSOUND@ @LIBESD@ @LIBSDL@
+ mp3blaster_DEPENDENCIES = ../mpegsound/libmpegsound.a ../nmixer/libnmixer.a
+-INCLUDES              = -I$(top_srcdir)/mpegsound -I/usr/include/ncurses -I$(top_srcdir)/nmixer -I$(includedir)
++INCLUDES              = -I$(top_srcdir)/mpegsound -I$(top_srcdir)/nmixer
+ mp3blaster_LDADD      = @LIBMPEGSOUND@ @LIBNMIXER@ @NAS_LIBS@ @SID_LIBS@ @OGG_LIBS@ @LIRC_LIBS@ @NCURSES_LIBS@ @LIBESD@ @LIBSDL@
+ EXTRA_DIST = FILES
+ AM_CXXFLAGS   = @NAS_CFLAGS@ -DMP3BLASTER_DOCDIR=\"${pkgdatadir}\"
diff --git a/recipes/mp3blaster/mp3blaster_3.2.5.bb b/recipes/mp3blaster/mp3blaster_3.2.5.bb
new file mode 100644 (file)
index 0000000..86d7af0
--- /dev/null
@@ -0,0 +1,15 @@
+LICENSE = "GPL"
+SECTION = "console/multimedia"
+DESCRIPTION = "A console MP3 player based on ncurses"
+DEPENDS = "ncurses libogg libvorbis"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/mp3blaster/mp3blaster-${PV}.tar.gz;name=tarball \
+           file://includedir.patch;patch=1"
+SRC_URI[tarball.md5sum] = "edb3bb122553d2d544dfb084010311c6"
+SRC_URI[tarball.sha256sum] = "129115742c77362cc3508eb7782702cfb44af2463a5453e8d19ea68abccedc29"
+
+
+
+inherit autotools
+
+EXTRA_OECONF = "--with-x=no --without-sidplay --with-oggvorbis --without-pth --without-mysql --without-nas"