php* : fix for autoconf 2.64+ problems
authorGraeme Gregory <dp@xora.org.uk>
Mon, 15 Mar 2010 23:47:36 +0000 (23:47 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Thu, 18 Mar 2010 19:42:37 +0000 (19:42 +0000)
Patch was taked from pld linux. As part of the debug happened to
update php-native to 5.3.2 so this is added as well.

recipes/php/php-5.2.13/php-m4-divert.patch [new file with mode: 0644]
recipes/php/php-5.2.6/php-m4-divert.patch [new file with mode: 0644]
recipes/php/php-5.3.0/php-m4-divert.patch [new file with mode: 0644]
recipes/php/php-5.3.2/acinclude-xml2-config.patch [new file with mode: 0644]
recipes/php/php-5.3.2/pear-makefile.patch [new file with mode: 0644]
recipes/php/php-5.3.2/php-m4-divert.patch [new file with mode: 0644]
recipes/php/php-native_5.3.2.bb [new file with mode: 0644]
recipes/php/php.inc
recipes/php/php_5.2.13.bb

diff --git a/recipes/php/php-5.2.13/php-m4-divert.patch b/recipes/php/php-5.2.13/php-m4-divert.patch
new file mode 100644 (file)
index 0000000..dfc7b64
--- /dev/null
@@ -0,0 +1,83 @@
+Patch taken from
+
+http://cvs.pld-linux.org/cgi-bin/cvsweb/packages/php/php-m4-divert.patch?rev=1.1
+
+diff -ur php-5.2.10.org/configure.in php-5.2.10/configure.in
+--- php-5.2.10.org/configure.in        2009-06-17 14:22:41.000000000 +0200
++++ php-5.2.10/configure.in    2009-08-18 12:16:25.317640253 +0200
+@@ -1,7 +1,7 @@
+ ## $Id: configure.in,v 1.579.2.52.2.139 2009/06/17 12:22:41 iliaa Exp $ -*- autoconf -*-
+ dnl ## Process this file with autoconf to produce a configure script.
+-divert(1)
++divert(1001)
+ dnl ## Diversion 1 is the autoconf + automake setup phase. We also
+ dnl ## set the PHP version, deal with platform-specific compile
+@@ -263,7 +263,7 @@
+ sinclude(TSRM/tsrm.m4)
+-divert(2)
++divert(1002)
+ dnl ## Diversion 2 is where we set PHP-specific options and come up
+ dnl ## with reasonable default values for them. We check for pthreads here
+@@ -302,7 +302,7 @@
+   PTHREADS_FLAGS
+ fi
+-divert(3)
++divert(1003)
+ dnl ## In diversion 3 we check for compile-time options to the PHP
+ dnl ## core and how to deal with different system dependencies.
+@@ -661,7 +661,7 @@
+   PHP_CRYPT_R_STYLE
+ fi
+-divert(4)
++divert(1004)
+ dnl ## In diversion 4 we check user-configurable general settings.
+@@ -902,7 +902,7 @@
+   AC_MSG_RESULT([using system default])
+ fi
+-divert(5)
++divert(1005)
+ dnl ## In diversion 5 we check which extensions should be compiled.
+ dnl ## All of these are normally in the extension directories.
+diff -ur php-5.2.10.org/ext/standard/config.m4 php-5.2.10/ext/standard/config.m4
+--- php-5.2.10.org/ext/standard/config.m4      2007-07-11 13:56:03.000000000 +0200
++++ php-5.2.10/ext/standard/config.m4  2009-08-18 12:16:25.317640253 +0200
+@@ -1,6 +1,6 @@
+ dnl $Id: config.m4,v 1.80.2.3.2.3 2007/07/11 11:56:03 jani Exp $ -*- autoconf -*-
+-divert(3)dnl
++divert(1003)dnl
+ dnl
+ dnl Check if flush should be called explicitly after buffered io
+@@ -205,7 +205,7 @@
+ AC_CHECK_FUNCS(getcwd getwd asinh acosh atanh log1p hypot glob strfmon nice fpclass isinf isnan)
+ AC_FUNC_FNMATCH       
+-divert(5)dnl
++divert(1005)dnl
+ dnl
+ dnl Check for regex library type
+diff -ur php-5.2.10.org/scripts/phpize.m4 php-5.2.10/scripts/phpize.m4
+--- php-5.2.10.org/scripts/phpize.m4   2009-06-02 21:54:22.000000000 +0200
++++ php-5.2.10/scripts/phpize.m4       2009-08-18 12:16:25.317640253 +0200
+@@ -1,6 +1,6 @@
+ dnl This file becomes configure.in for self-contained extensions.
+-divert(1)
++divert(1001)
+ AC_PREREQ(2.13)
+ AC_INIT(config.m4)
diff --git a/recipes/php/php-5.2.6/php-m4-divert.patch b/recipes/php/php-5.2.6/php-m4-divert.patch
new file mode 100644 (file)
index 0000000..dfc7b64
--- /dev/null
@@ -0,0 +1,83 @@
+Patch taken from
+
+http://cvs.pld-linux.org/cgi-bin/cvsweb/packages/php/php-m4-divert.patch?rev=1.1
+
+diff -ur php-5.2.10.org/configure.in php-5.2.10/configure.in
+--- php-5.2.10.org/configure.in        2009-06-17 14:22:41.000000000 +0200
++++ php-5.2.10/configure.in    2009-08-18 12:16:25.317640253 +0200
+@@ -1,7 +1,7 @@
+ ## $Id: configure.in,v 1.579.2.52.2.139 2009/06/17 12:22:41 iliaa Exp $ -*- autoconf -*-
+ dnl ## Process this file with autoconf to produce a configure script.
+-divert(1)
++divert(1001)
+ dnl ## Diversion 1 is the autoconf + automake setup phase. We also
+ dnl ## set the PHP version, deal with platform-specific compile
+@@ -263,7 +263,7 @@
+ sinclude(TSRM/tsrm.m4)
+-divert(2)
++divert(1002)
+ dnl ## Diversion 2 is where we set PHP-specific options and come up
+ dnl ## with reasonable default values for them. We check for pthreads here
+@@ -302,7 +302,7 @@
+   PTHREADS_FLAGS
+ fi
+-divert(3)
++divert(1003)
+ dnl ## In diversion 3 we check for compile-time options to the PHP
+ dnl ## core and how to deal with different system dependencies.
+@@ -661,7 +661,7 @@
+   PHP_CRYPT_R_STYLE
+ fi
+-divert(4)
++divert(1004)
+ dnl ## In diversion 4 we check user-configurable general settings.
+@@ -902,7 +902,7 @@
+   AC_MSG_RESULT([using system default])
+ fi
+-divert(5)
++divert(1005)
+ dnl ## In diversion 5 we check which extensions should be compiled.
+ dnl ## All of these are normally in the extension directories.
+diff -ur php-5.2.10.org/ext/standard/config.m4 php-5.2.10/ext/standard/config.m4
+--- php-5.2.10.org/ext/standard/config.m4      2007-07-11 13:56:03.000000000 +0200
++++ php-5.2.10/ext/standard/config.m4  2009-08-18 12:16:25.317640253 +0200
+@@ -1,6 +1,6 @@
+ dnl $Id: config.m4,v 1.80.2.3.2.3 2007/07/11 11:56:03 jani Exp $ -*- autoconf -*-
+-divert(3)dnl
++divert(1003)dnl
+ dnl
+ dnl Check if flush should be called explicitly after buffered io
+@@ -205,7 +205,7 @@
+ AC_CHECK_FUNCS(getcwd getwd asinh acosh atanh log1p hypot glob strfmon nice fpclass isinf isnan)
+ AC_FUNC_FNMATCH       
+-divert(5)dnl
++divert(1005)dnl
+ dnl
+ dnl Check for regex library type
+diff -ur php-5.2.10.org/scripts/phpize.m4 php-5.2.10/scripts/phpize.m4
+--- php-5.2.10.org/scripts/phpize.m4   2009-06-02 21:54:22.000000000 +0200
++++ php-5.2.10/scripts/phpize.m4       2009-08-18 12:16:25.317640253 +0200
+@@ -1,6 +1,6 @@
+ dnl This file becomes configure.in for self-contained extensions.
+-divert(1)
++divert(1001)
+ AC_PREREQ(2.13)
+ AC_INIT(config.m4)
diff --git a/recipes/php/php-5.3.0/php-m4-divert.patch b/recipes/php/php-5.3.0/php-m4-divert.patch
new file mode 100644 (file)
index 0000000..dfc7b64
--- /dev/null
@@ -0,0 +1,83 @@
+Patch taken from
+
+http://cvs.pld-linux.org/cgi-bin/cvsweb/packages/php/php-m4-divert.patch?rev=1.1
+
+diff -ur php-5.2.10.org/configure.in php-5.2.10/configure.in
+--- php-5.2.10.org/configure.in        2009-06-17 14:22:41.000000000 +0200
++++ php-5.2.10/configure.in    2009-08-18 12:16:25.317640253 +0200
+@@ -1,7 +1,7 @@
+ ## $Id: configure.in,v 1.579.2.52.2.139 2009/06/17 12:22:41 iliaa Exp $ -*- autoconf -*-
+ dnl ## Process this file with autoconf to produce a configure script.
+-divert(1)
++divert(1001)
+ dnl ## Diversion 1 is the autoconf + automake setup phase. We also
+ dnl ## set the PHP version, deal with platform-specific compile
+@@ -263,7 +263,7 @@
+ sinclude(TSRM/tsrm.m4)
+-divert(2)
++divert(1002)
+ dnl ## Diversion 2 is where we set PHP-specific options and come up
+ dnl ## with reasonable default values for them. We check for pthreads here
+@@ -302,7 +302,7 @@
+   PTHREADS_FLAGS
+ fi
+-divert(3)
++divert(1003)
+ dnl ## In diversion 3 we check for compile-time options to the PHP
+ dnl ## core and how to deal with different system dependencies.
+@@ -661,7 +661,7 @@
+   PHP_CRYPT_R_STYLE
+ fi
+-divert(4)
++divert(1004)
+ dnl ## In diversion 4 we check user-configurable general settings.
+@@ -902,7 +902,7 @@
+   AC_MSG_RESULT([using system default])
+ fi
+-divert(5)
++divert(1005)
+ dnl ## In diversion 5 we check which extensions should be compiled.
+ dnl ## All of these are normally in the extension directories.
+diff -ur php-5.2.10.org/ext/standard/config.m4 php-5.2.10/ext/standard/config.m4
+--- php-5.2.10.org/ext/standard/config.m4      2007-07-11 13:56:03.000000000 +0200
++++ php-5.2.10/ext/standard/config.m4  2009-08-18 12:16:25.317640253 +0200
+@@ -1,6 +1,6 @@
+ dnl $Id: config.m4,v 1.80.2.3.2.3 2007/07/11 11:56:03 jani Exp $ -*- autoconf -*-
+-divert(3)dnl
++divert(1003)dnl
+ dnl
+ dnl Check if flush should be called explicitly after buffered io
+@@ -205,7 +205,7 @@
+ AC_CHECK_FUNCS(getcwd getwd asinh acosh atanh log1p hypot glob strfmon nice fpclass isinf isnan)
+ AC_FUNC_FNMATCH       
+-divert(5)dnl
++divert(1005)dnl
+ dnl
+ dnl Check for regex library type
+diff -ur php-5.2.10.org/scripts/phpize.m4 php-5.2.10/scripts/phpize.m4
+--- php-5.2.10.org/scripts/phpize.m4   2009-06-02 21:54:22.000000000 +0200
++++ php-5.2.10/scripts/phpize.m4       2009-08-18 12:16:25.317640253 +0200
+@@ -1,6 +1,6 @@
+ dnl This file becomes configure.in for self-contained extensions.
+-divert(1)
++divert(1001)
+ AC_PREREQ(2.13)
+ AC_INIT(config.m4)
diff --git a/recipes/php/php-5.3.2/acinclude-xml2-config.patch b/recipes/php/php-5.3.2/acinclude-xml2-config.patch
new file mode 100644 (file)
index 0000000..bf519d2
--- /dev/null
@@ -0,0 +1,18 @@
+--- /orig-acinclude.m4 2007-02-20 15:03:25.000000000 +0200
++++ /acinclude.m4      2007-02-20 15:03:24.000000000 +0200
+@@ -2359,12 +2359,9 @@
+ AC_DEFUN([PHP_SETUP_LIBXML], [
+ AC_CACHE_CHECK([for xml2-config path], ac_cv_php_xml2_config_path,
+ [
+-  for i in $PHP_LIBXML_DIR /usr/local /usr; do
+-    if test -x "$i/bin/xml2-config"; then
+-      ac_cv_php_xml2_config_path="$i/bin/xml2-config"
+-      break
+-    fi
+-  done
++
++      ac_cv_php_xml2_config_path="$PHP_LIBXML_DIR/xml2-config"
++
+ ])
+
+   if test -x "$ac_cv_php_xml2_config_path"; then
diff --git a/recipes/php/php-5.3.2/pear-makefile.patch b/recipes/php/php-5.3.2/pear-makefile.patch
new file mode 100644 (file)
index 0000000..26de98a
--- /dev/null
@@ -0,0 +1,11 @@
+--- /pear/orig-Makefile.frag   2007-03-16 12:18:33.000000000 +0200
++++ /pear/Makefile.frag        2007-03-16 12:35:48.000000000 +0200
+@@ -6,7 +6,7 @@
+ PEAR_INSTALL_FLAGS = -n -dshort_open_tag=0 -dsafe_mode=0 -dopen_basedir= -derror_reporting=E_ALL -dmemory_limit=-1 -ddetect_unicode=0
+ install-pear-installer: $(SAPI_CLI_PATH)
+-      @$(top_builddir)/sapi/cli/php $(PEAR_INSTALL_FLAGS) $(builddir)/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)"
++      @$(PHP_NATIVE_DIR)/php $(PEAR_INSTALL_FLAGS) $(builddir)/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)"
+ install-pear:
+       @echo "Installing PEAR environment:      $(INSTALL_ROOT)$(peardir)/"
diff --git a/recipes/php/php-5.3.2/php-m4-divert.patch b/recipes/php/php-5.3.2/php-m4-divert.patch
new file mode 100644 (file)
index 0000000..dfc7b64
--- /dev/null
@@ -0,0 +1,83 @@
+Patch taken from
+
+http://cvs.pld-linux.org/cgi-bin/cvsweb/packages/php/php-m4-divert.patch?rev=1.1
+
+diff -ur php-5.2.10.org/configure.in php-5.2.10/configure.in
+--- php-5.2.10.org/configure.in        2009-06-17 14:22:41.000000000 +0200
++++ php-5.2.10/configure.in    2009-08-18 12:16:25.317640253 +0200
+@@ -1,7 +1,7 @@
+ ## $Id: configure.in,v 1.579.2.52.2.139 2009/06/17 12:22:41 iliaa Exp $ -*- autoconf -*-
+ dnl ## Process this file with autoconf to produce a configure script.
+-divert(1)
++divert(1001)
+ dnl ## Diversion 1 is the autoconf + automake setup phase. We also
+ dnl ## set the PHP version, deal with platform-specific compile
+@@ -263,7 +263,7 @@
+ sinclude(TSRM/tsrm.m4)
+-divert(2)
++divert(1002)
+ dnl ## Diversion 2 is where we set PHP-specific options and come up
+ dnl ## with reasonable default values for them. We check for pthreads here
+@@ -302,7 +302,7 @@
+   PTHREADS_FLAGS
+ fi
+-divert(3)
++divert(1003)
+ dnl ## In diversion 3 we check for compile-time options to the PHP
+ dnl ## core and how to deal with different system dependencies.
+@@ -661,7 +661,7 @@
+   PHP_CRYPT_R_STYLE
+ fi
+-divert(4)
++divert(1004)
+ dnl ## In diversion 4 we check user-configurable general settings.
+@@ -902,7 +902,7 @@
+   AC_MSG_RESULT([using system default])
+ fi
+-divert(5)
++divert(1005)
+ dnl ## In diversion 5 we check which extensions should be compiled.
+ dnl ## All of these are normally in the extension directories.
+diff -ur php-5.2.10.org/ext/standard/config.m4 php-5.2.10/ext/standard/config.m4
+--- php-5.2.10.org/ext/standard/config.m4      2007-07-11 13:56:03.000000000 +0200
++++ php-5.2.10/ext/standard/config.m4  2009-08-18 12:16:25.317640253 +0200
+@@ -1,6 +1,6 @@
+ dnl $Id: config.m4,v 1.80.2.3.2.3 2007/07/11 11:56:03 jani Exp $ -*- autoconf -*-
+-divert(3)dnl
++divert(1003)dnl
+ dnl
+ dnl Check if flush should be called explicitly after buffered io
+@@ -205,7 +205,7 @@
+ AC_CHECK_FUNCS(getcwd getwd asinh acosh atanh log1p hypot glob strfmon nice fpclass isinf isnan)
+ AC_FUNC_FNMATCH       
+-divert(5)dnl
++divert(1005)dnl
+ dnl
+ dnl Check for regex library type
+diff -ur php-5.2.10.org/scripts/phpize.m4 php-5.2.10/scripts/phpize.m4
+--- php-5.2.10.org/scripts/phpize.m4   2009-06-02 21:54:22.000000000 +0200
++++ php-5.2.10/scripts/phpize.m4       2009-08-18 12:16:25.317640253 +0200
+@@ -1,6 +1,6 @@
+ dnl This file becomes configure.in for self-contained extensions.
+-divert(1)
++divert(1001)
+ AC_PREREQ(2.13)
+ AC_INIT(config.m4)
diff --git a/recipes/php/php-native_5.3.2.bb b/recipes/php/php-native_5.3.2.bb
new file mode 100644 (file)
index 0000000..10c308a
--- /dev/null
@@ -0,0 +1,7 @@
+require php-native.inc
+
+PR = "r0"
+
+SRC_URI[src.md5sum] = "46f500816125202c48a458d0133254a4"
+SRC_URI[src.sha256sum] = "9a380a574adcb3a9abe3226e7c3a9bae619e8a1b90842ec2a7edf0ad92afdeda"
+
index 6f30690..cbec13d 100644 (file)
@@ -3,8 +3,9 @@ HOMEPAGE = "http://www.php.net"
 SECTION = "console/network"
 LICENSE = "PHP"
 
-SRC_URI =     "http://us2.php.net/distributions/php-${PV}.tar.bz2;name=src\
-               file://acinclude-xml2-config.patch;patch=1"
+SRC_URI =     "http://us2.php.net/distributions/php-${PV}.tar.bz2;name=src \
+               file://acinclude-xml2-config.patch;patch=1 \
+               file://php-m4-divert.patch;patch=1"
 
 S = "${WORKDIR}/php-${PV}"
 
index 97b68ba..5f446d4 100644 (file)
@@ -3,7 +3,7 @@ require php.inc
 DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native mysql5 \
            libc-client openssl"
 
-PR = "r4"
+PR = "r5"
 
 SRC_URI += "file://pear-makefile.patch;patch=1 \
             file://imap-fix-autofoo.patch;patch=1 \